summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9bd3aeab8b17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gitlpm-git
+ pkgdesc = Graphs your lpm (lines per minute) between commits
+ pkgver = r8.fc562d0
+ pkgrel = 1
+ url = https://github.com/csculley/gitlpm.git
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python
+ depends = gawk
+ depends = gnuplot
+ provides = gitlpm
+ conflicts = gitlpm
+ source = gitlpm::git+https://github.com/csculley/gitlpm.git#branch=master
+ md5sums = SKIP
+
+pkgname = gitlpm-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb41bd9478ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Christopher Sculley <cs.sculley@gmail.com>
+pkgname=gitlpm-git
+pkgver=r8.fc562d0
+pkgrel=1
+pkgdesc="Graphs your lpm (lines per minute) between commits"
+arch=('any')
+license=('GPL3')
+url="https://github.com/csculley/gitlpm.git"
+depends=('python' 'gawk' 'gnuplot')
+makedepends=('git')
+provides=('gitlpm')
+conflicts=('gitlpm')
+source=('gitlpm::git+https://github.com/csculley/gitlpm.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ mv gitlpm "$pkgname"
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir"/usr/bin
+ mv gitlpm.py gitlpm
+ chmod +x gitlpm
+ cp gitlpm "$pkgdir"/usr/bin
+}