summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc37d3012c73..fee4d05f2769 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gitmux-bin
pkgdesc = Git in your tmux status bar
- pkgver = 0.7.9
- pkgrel = 3
+ pkgver = 0.7.10
+ pkgrel = 1
url = https://github.com/arl/gitmux
arch = x86_64
arch = i686
@@ -10,13 +10,11 @@ pkgbase = gitmux-bin
depends = tmux
provides = gitmux
conflicts = gitmux
- source = https://raw.githubusercontent.com/arl/gitmux/main/LICENSE
- sha256sums = 051c31312c5af0e4e4d2559546a8a0f36ce2bf9b50e2d00a81e6a3b31666a3ec
- source_x86_64 = gitmux-0.7.9-amd64.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_amd64.tar.gz
- sha256sums_x86_64 = 156f98946cc437572576c69f062f287e4d0e5a98855bd47cd6a2f15c9e385107
- source_i686 = gitmux-0.7.9-386.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_386.tar.gz
- sha256sums_i686 = 60ad0033546362bd016e6c820637358b07e08aae999e5ec0956311be115767f7
- source_aarch64 = gitmux-0.7.9-arm64.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.9/gitmux_0.7.9_linux_arm64.tar.gz
- sha256sums_aarch64 = 959111d5de93aecc87cb706cc3729fce93b27b3a31a7bfbc4d9d1bc7bb93391e
+ source_x86_64 = gitmux-0.7.10-amd64.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.10/gitmux_0.7.10_linux_amd64.tar.gz
+ sha256sums_x86_64 = 99d25aa57d2b255a1969b1c068121702dcce019de5f8c23bf398a1f6e520ffb5
+ source_i686 = gitmux-0.7.10-386.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.10/gitmux_0.7.10_linux_386.tar.gz
+ sha256sums_i686 = 6d009c6dc467cf8138a3b3a26fc7aa001911a10bf8b3b7f15a19e81f75052301
+ source_aarch64 = gitmux-0.7.10-arm64.tar.gz::https://github.com/arl/gitmux/releases/download/v0.7.10/gitmux_0.7.10_linux_arm64.tar.gz
+ sha256sums_aarch64 = a7209f9ef368e5e723ddb5719bc05b09ce119af4a91965a5fb90f3ca5036cc68
pkgname = gitmux-bin
diff --git a/PKGBUILD b/PKGBUILD
index 52fb63efb6db..b52c894a7484 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=gitmux-bin
_pkgname="${pkgname%-bin}"
-pkgver=0.7.9
-pkgrel=3
+pkgver=0.7.10
+pkgrel=1
pkgdesc="Git in your tmux status bar"
arch=('x86_64' 'i686' 'aarch64')
url="https://github.com/arl/gitmux"
@@ -11,19 +11,19 @@ license=('MIT')
depends=('tmux')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("https://raw.githubusercontent.com/arl/gitmux/main/LICENSE")
source_x86_64=("${_pkgname}-${pkgver}-amd64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_amd64.tar.gz")
source_i686=("${_pkgname}-${pkgver}-386.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_386.tar.gz")
source_aarch64=("${_pkgname}-${pkgver}-arm64.tar.gz::${url}/releases/download/v${pkgver}/${_pkgname}_${pkgver}_linux_arm64.tar.gz")
-sha256sums=('051c31312c5af0e4e4d2559546a8a0f36ce2bf9b50e2d00a81e6a3b31666a3ec')
-sha256sums_x86_64=('156f98946cc437572576c69f062f287e4d0e5a98855bd47cd6a2f15c9e385107')
-sha256sums_i686=('60ad0033546362bd016e6c820637358b07e08aae999e5ec0956311be115767f7')
-sha256sums_aarch64=('959111d5de93aecc87cb706cc3729fce93b27b3a31a7bfbc4d9d1bc7bb93391e')
+sha256sums_x86_64=('99d25aa57d2b255a1969b1c068121702dcce019de5f8c23bf398a1f6e520ffb5')
+sha256sums_i686=('6d009c6dc467cf8138a3b3a26fc7aa001911a10bf8b3b7f15a19e81f75052301')
+sha256sums_aarch64=('a7209f9ef368e5e723ddb5719bc05b09ce119af4a91965a5fb90f3ca5036cc68')
package() {
cd "${srcdir}"
install -Dm 755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm 644 "LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
}