summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f70eb05521e8..e495d1ea7843 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gittyup-git
pkgdesc = Graphical Git client (GitAhead fork)
- pkgver = 1.3.0.r26.g34625fb
- pkgrel = 3
+ pkgver = 1.3.0.r129.g66bc256e
+ pkgrel = 2
url = https://github.com/Murmele/Gittyup
arch = x86_64
license = MIT
@@ -16,11 +16,17 @@ pkgbase = gittyup-git
depends = cmark
depends = pcre
depends = libssh2
+ depends = hicolor-icon-theme
+ depends = glibc
+ depends = gcc-libs
+ depends = zlib
+ depends = openssl
optdepends = git-lfs: git-lfs support
optdepends = libgnome-keyring: for GNOME Keyring for auth credentials
optdepends = qt5-translations: translations
provides = gittyup
conflicts = gittyup
+ options = !lto
source = git+https://github.com/Murmele/Gittyup.git
source = stinb-libgit2::git+https://github.com/stinb/libgit2.git
source = git+https://github.com/kuba--/zip.git
diff --git a/PKGBUILD b/PKGBUILD
index 4cab22b5b6e8..f2d387790a78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,24 @@
# Contributor: Whovian9369 <Whovian9369@gmail.com>
pkgname=gittyup-git
-pkgver=1.3.0.r26.g34625fb
-pkgrel=3
+pkgver=1.3.0.r129.g66bc256e
+pkgrel=2
pkgdesc="Graphical Git client (GitAhead fork)"
url="https://github.com/Murmele/Gittyup"
arch=(x86_64)
license=(MIT)
-depends=(qt5-base hunspell lua cmark pcre libssh2)
+depends=(qt5-base hunspell lua cmark pcre libssh2
+
+ # namcap implict depends
+ hicolor-icon-theme glibc gcc-libs zlib openssl
+)
makedepends=(git cmake ninja qt5-tools qt5-translations ) #libgit2 libgnome-keyring
optdepends=('git-lfs: git-lfs support'
'libgnome-keyring: for GNOME Keyring for auth credentials'
'qt5-translations: translations')
provides=(gittyup)
conflicts=(gittyup)
+options=(!lto)
source=("git+https://github.com/Murmele/Gittyup.git"
"stinb-libgit2::git+https://github.com/stinb/libgit2.git"
"git+https://github.com/kuba--/zip.git"
@@ -69,6 +74,7 @@ build() {
-DUSE_SYSTEM_LIBSSH2=ON \
-DUSE_SYSTEM_LUA=ON \
-DUSE_SYSTEM_OPENSSL=ON \
+ -DLUA_MODULES_PATH=/usr/lib/ \
-DUSE_SYSTEM_QT=ON
ninja