summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3402735bcd49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = givemelyrics
+ pkgdesc = See the lyrics of the song that is playing, from any application
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/muriloventuroso/givemelyrics
+ arch = x86_64
+ license = GPL3
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ source = https://github.com/muriloventuroso/givemelyrics/archive/0.5.0/givemelyrics-0.5.0.tar.gz
+ sha256sums = 574fdd887715cffeed814b53b2c745bd69260ca584712376ec2b10d3b5af8563
+
+pkgname = givemelyrics
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc89714da09c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=givemelyrics
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='See the lyrics of the song that is playing, from any application'
+arch=('x86_64')
+url='https://github.com/muriloventuroso/givemelyrics'
+license=('GPL3')
+depends=('granite')
+makedepends=('meson' 'vala')
+source=("https://github.com/muriloventuroso/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('574fdd887715cffeed814b53b2c745bd69260ca584712376ec2b10d3b5af8563')
+
+build() {
+ arch-meson $pkgname-$pkgver build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}