summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..079d591dbcd2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gkrellmapcupsd
+ pkgdesc = Gkrellm apcupsd monitor. Monitors line voltage, charge, time left, load. Works fine if you do not change the config. Otherwise, gkrellm will crash.
+ pkgver = 0.02
+ pkgrel = 3
+ url = http://www.unixdev.net/projects/gkrellmapcupsd
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gkrellm
+ source = ftp://ftp.unixdev.net/pub/unixdev/gkrellmapcupsd/0.02/gkrellmapcupsd_0.02.tar.gz
+ md5sums = 37179b274e07c0b7c308392f9f8524ad
+
+pkgname = gkrellmapcupsd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93800def5178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: dax <dax@deelab.org>
+pkgname=gkrellmapcupsd
+pkgver=0.02
+pkgrel=3
+pkgdesc="Gkrellm apcupsd monitor. Monitors line voltage, charge, time left, load. Works fine if you do not change the config. Otherwise, gkrellm will crash."
+arch=('i686' 'x86_64')
+url="http://www.unixdev.net/projects/gkrellmapcupsd"
+license=('GPL')
+depends=('gkrellm')
+source=("ftp://ftp.unixdev.net/pub/unixdev/gkrellmapcupsd/0.02/${pkgname}_${pkgver}.tar.gz")
+md5sums=('37179b274e07c0b7c308392f9f8524ad')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -D -m644 gkrellmapcupsd.so "$pkgdir/usr/lib/gkrellm2/plugins/gkrellmapcupsd.so"
+}