summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..984f569669e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gkx86info
+ pkgdesc = GKrellM plugin to display CPU speed (useful for clock stepping)
+ pkgver = 0.0.2
+ pkgrel = 3
+ url = http://anchois.free.fr
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gkrellm
+ source = http://anchois.free.fr/gkx86info2-0.0.2.tar.gz
+ md5sums = e893ac5db865b4621c9f880686d30a99
+
+pkgname = gkx86info
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..623ac43ca0d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD,v 1.4 2004/04/19 06:24:58 dorphell Exp $
+# Maintainer: eric <eric@archlinux.org>
+# Contributor: Manolis Tzanidakis
+#
+
+pkgname=gkx86info
+pkgver=0.0.2
+pkgrel=3
+pkgdesc="GKrellM plugin to display CPU speed (useful for clock stepping)"
+depends=('gkrellm')
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="http://anchois.free.fr"
+source=(http://anchois.free.fr/gkx86info2-${pkgver}.tar.gz)
+md5sums=('e893ac5db865b4621c9f880686d30a99')
+
+build() {
+ cd "$srcdir/${pkgname}${pkgver}"
+ gcc $CFLAGS -fPIC `pkg-config gtk+-2.0 --cflags` -c gkx86info.c
+ gcc $CFLAGS -fPIC -o MHz.o -c MHz.c
+ gcc -shared -o gkx86info.so MHz.o gkx86info.o
+}
+package() {
+ cd "$srcdir/${pkgname}${pkgver}"
+ install -Dm755 $pkgname.so "$pkgdir/usr/lib/gkrellm2/plugins/$pkgname.so"
+}