summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..289b1b3aba7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = glorious-man-pages-git
+ pkgdesc = Man pages for the computer peripherals from Glorious PC Gaming Race
+ pkgver = cef6a2e
+ pkgrel = 1
+ url = https://gitlab.com/gabmus/glorious-man-pages
+ arch = any
+ license = CC0
+ makedepends = git
+ makedepends = make
+ makedepends = pandoc
+ depends = man-pages
+ provides = glorious-man-pages
+ conflicts = glorious-man-pages
+ source = gmp::git+https://gitlab.com/gabmus/glorious-man-pages
+ sha256sums = SKIP
+
+pkgname = glorious-man-pages-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4295380ab0a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gabriele Musco <gabmus@disroot.org>
+# Upstream URL: https://gitlab.gnome.org/gabmus/whatip
+
+pkgname=glorious-man-pages-git
+pkgver=cef6a2e
+pkgrel=1
+pkgdesc='Man pages for the computer peripherals from Glorious PC Gaming Race'
+arch=('any')
+url='https://gitlab.com/gabmus/glorious-man-pages'
+license=('CC0')
+depends=(
+ 'man-pages'
+)
+makedepends=('git' 'make' 'pandoc')
+provides=('glorious-man-pages')
+conflicts=('glorious-man-pages')
+source=("gmp::git+https://gitlab.com/gabmus/glorious-man-pages")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/gmp"
+ git describe --long --tags --always | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/gmp"
+ make all
+}
+
+package() {
+ cd "$srcdir/gmp"
+ DESTDIR="$pkgdir" make install
+}