summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c75bbf0bd101..e3486ad3c702 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = glpk-git
pkgdesc = GNU Linear Programming Kit: solve LP, MIP and other problems
- pkgver = r275.g4e03800
+ pkgver = 5.0.r242.g4e03800
pkgrel = 1
url = https://www.gnu.org/software/glpk/
arch = i686
@@ -9,11 +9,10 @@ pkgbase = glpk-git
makedepends = git
depends = glibc
depends = gmp
- provides = glpk
+ provides = glpk=5.0.r242.g4e03800
conflicts = glpk
options = staticlibs
source = git+https://salsa.debian.org/science-team/glpk.git
sha256sums = SKIP
pkgname = glpk-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 93e77f6855d4..fbd22ebd4711 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=glpk-git
-pkgver=r275.g4e03800
+pkgver=5.0.r242.g4e03800
pkgrel=1
pkgdesc="GNU Linear Programming Kit: solve LP, MIP and other problems"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.gnu.org/software/glpk/"
license=('GPL')
depends=('glibc' 'gmp')
makedepends=('git')
-provides=('glpk')
+provides=("glpk=$pkgver")
conflicts=('glpk')
options=('staticlibs')
source=("git+https://salsa.debian.org/science-team/glpk.git")
@@ -19,9 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "glpk"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^upstream/[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's|^upstream/||'
}
build() {