summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3d09c60acb42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = glvis
+ pkgdesc = A PVS (Potentially Visible Set) builder specially designed to be used with OpenGL ports of the DOOM game engine.
+ pkgver = 1.6
+ pkgrel = 2
+ url = http://vavoom-engine.com/glvis.php
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://downloads.sourceforge.net/vavoom/glvis-1.6.tar.gz
+ md5sums = d75dff784e3b5cb193a5cd6011ce812e
+
+pkgname = glvis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adca093cebf7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jasper Follas follasjj@live.co.uk
+
+pkgname=glvis
+pkgver=1.6
+pkgrel=2
+pkgdesc="A PVS (Potentially Visible Set) builder specially designed to
+be used with OpenGL ports of the DOOM game engine."
+arch=('i686' 'x86_64')
+url="http://vavoom-engine.com/glvis.php"
+license=('GPL')
+source=(http://downloads.sourceforge.net/vavoom/$pkgname-$pkgver.tar.gz)
+md5sums=('d75dff784e3b5cb193a5cd6011ce812e')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ sh autogen.sh
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+}