summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df1190976feb..971975e2aa22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = gmt-dcw
pkgdesc = The Digital Chart of the World Polygon data for the Generic Mapping Tools.
- pkgver = 2.1.1
+ pkgver = 2.1.2
pkgrel = 1
url = https://github.com/GenericMappingTools/dcw-gmt
arch = any
license = LGPL
depends = gmt>=6.1.1
- source = https://github.com/GenericMappingTools/dcw-gmt/releases/download/2.1.1/dcw-gmt-2.1.1.tar.gz
- sha256sums = d4e208dca88fbf42cba1bb440fbd96ea2f932185c86001f327ed0c7b65d27af1
+ source = gmt-dcw-2.1.2.tar.gz::https://github.com/GenericMappingTools/dcw-gmt/releases/download/2.1.2/dcw-gmt-2.1.2.tar.gz
+ sha256sums = 4bb840d075c8ba3e14aeb41cf17c24236bff787566314f9ff758ab9977745d99
pkgname = gmt-dcw
diff --git a/PKGBUILD b/PKGBUILD
index 6e3bfc7aa72f..ec144170a615 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=gmt-dcw
-pkgver=2.1.1
+pkgver=2.1.2
pkgrel=1
pkgdesc="The Digital Chart of the World Polygon data for the Generic Mapping Tools."
arch=('any')
url="https://github.com/GenericMappingTools/dcw-gmt"
license=('LGPL')
depends=('gmt>=6.1.1')
-source=("${url}/releases/download/${pkgver}/dcw-gmt-${pkgver}.tar.gz")
-sha256sums=('d4e208dca88fbf42cba1bb440fbd96ea2f932185c86001f327ed0c7b65d27af1')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/releases/download/${pkgver}/dcw-gmt-${pkgver}.tar.gz")
+sha256sums=('4bb840d075c8ba3e14aeb41cf17c24236bff787566314f9ff758ab9977745d99')
package() {
- install -d "${pkgdir}/usr/share/gmt/dcw"
- install -m 644 "dcw-gmt-${pkgver}"/* "${pkgdir}/usr/share/gmt/dcw/"
+ cd "dcw-gmt-${pkgver}"
+ install -Dm0644 -t "${pkgdir}/usr/share/gmt/dcw" dcw-*
+ install -Dm0644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE
}
# vim:set ts=4 sw=4 et: