summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
-rw-r--r--gngeo.desktop2
3 files changed, 22 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8a136c37591..7457209e0fc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = gngeo-hg
- pkgdesc = A portable command-line NeoGeo Emulator (development version).
+ pkgdesc = A portable command-line NeoGeo Emulator (development version)
pkgver = 0.8.r95.6ad2a3d1bba3
pkgrel = 1
url = https://code.google.com/p/gngeo/
install = gngeo-hg.install
arch = i686
arch = x86_64
- license = GPL
- license = custom
+ license = custom GPL
makedepends = mercurial
makedepends = nasm
+ makedepends = glu
depends = zlib
depends = sdl
optdepends = libgl: OpenGL renderer backend
@@ -19,12 +19,8 @@ pkgbase = gngeo-hg
source = gngeo.desktop
source = gngeo.png
source = gngeo-hg.install
- md5sums = SKIP
- md5sums = 0e45bc9cf87a61bd3b92fb27c6a87dbd
- md5sums = 25321e134708b239199c6ba49a9a2248
- md5sums = fa2be7e60f3390bbd4137f0dd593a2f7
sha256sums = SKIP
- sha256sums = f1844db27e0f2d8046a107b0279c76c19a89f7d824da80590e93ea24382c3785
+ sha256sums = b66038445a4ac8f2fdc088a37013bc14cd2cca86e5bb2c5a68aa7942c17662d2
sha256sums = b543425d51bd669fe5081b0b89492f18163c292194ac2a4acff683ba2a60063e
sha256sums = a1fe0ad7b8f601abcca92650e225c28af45db0b9eb4d96f3bdc055af0fe5c635
diff --git a/PKGBUILD b/PKGBUILD
index da8275b74eee..587efdade8c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,32 @@
-# Maintainer: carstene1ns <arch carsten-teibes de>
+# Maintainer: carstene1ns <url/mail: arch carsten-teibes de>
_pkgbase=gngeo
pkgname=$_pkgbase-hg
pkgver=0.8.r95.6ad2a3d1bba3
pkgrel=1
-pkgdesc="A portable command-line NeoGeo Emulator (development version)."
+pkgdesc="A portable command-line NeoGeo Emulator (development version)"
arch=('i686' 'x86_64')
url="https://code.google.com/p/gngeo/"
-license=('GPL' 'custom')
+license=('custom GPL')
depends=('zlib' 'sdl')
optdepends=('libgl: OpenGL renderer backend')
-makedepends=('mercurial' 'nasm')
+makedepends=('mercurial' 'nasm' 'glu')
# nasm is x86-only
-[ "$CARCH" == "x86_64" ] && makedepends=('mercurial')
+[ "$CARCH" == "x86_64" ] && makedepends=('mercurial' 'glu')
conflicts=("$_pkgbase")
provides=("$_pkgbase")
-install="$pkgname.install"
-source=("$_pkgbase"::"hg+$url"
+install=$pkgname.install
+source=($_pkgbase::"hg+$url"
"$_pkgbase.desktop"
"$_pkgbase.png"
"$pkgname.install")
-md5sums=('SKIP'
- '0e45bc9cf87a61bd3b92fb27c6a87dbd'
- '25321e134708b239199c6ba49a9a2248'
- 'fa2be7e60f3390bbd4137f0dd593a2f7')
sha256sums=('SKIP'
- 'f1844db27e0f2d8046a107b0279c76c19a89f7d824da80590e93ea24382c3785'
+ 'b66038445a4ac8f2fdc088a37013bc14cd2cca86e5bb2c5a68aa7942c17662d2'
'b543425d51bd669fe5081b0b89492f18163c292194ac2a4acff683ba2a60063e'
'a1fe0ad7b8f601abcca92650e225c28af45db0b9eb4d96f3bdc055af0fe5c635')
pkgver() {
- cd "$srcdir/$_pkgbase"
+ cd $_pkgbase
# get latest tag, revision count and commit identifier
printf "%s.r%s.%s" "$(hg parents --template {latesttag} | sed 's/gngeo_//')" \
@@ -38,29 +34,28 @@ pkgver() {
}
prepare() {
- cd "$srcdir/$_pkgbase"
+ cd $_pkgbase
# change path
sed 's#games/lib#share#' -i sample_gngeorc
}
build() {
- cd "$srcdir/$_pkgbase"
+ cd $_pkgbase
./configure --prefix=/usr
-
# force single threaded build
make -j1
}
package() {
- cd "$srcdir/$_pkgbase"
+ cd $_pkgbase
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir/" install
# install icon, .desktop, sample config and license file
- install -Dm644 "$srcdir/$_pkgbase.png" "$pkgdir/usr/share/pixmaps/$_pkgbase.png"
- install -Dm644 "$srcdir/$_pkgbase.desktop" "$pkgdir/usr/share/applications/$_pkgbase.desktop"
- install -Dm644 sample_gngeorc "$pkgdir/usr/share/$_pkgbase/sample_gngeorc"
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgbase/COPYING"
+ install -Dm644 ../$_pkgbase.png "$pkgdir"/usr/share/pixmaps/$_pkgbase.png
+ install -Dm644 ../$_pkgbase.desktop "$pkgdir"/usr/share/applications/$_pkgbase.desktop
+ install -Dm644 sample_gngeorc "$pkgdir"/usr/share/$_pkgbase/sample_gngeorc
+ install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$_pkgbase/COPYING
}
diff --git a/gngeo.desktop b/gngeo.desktop
index 9981b37892dc..15d1fc2aebe8 100644
--- a/gngeo.desktop
+++ b/gngeo.desktop
@@ -6,4 +6,4 @@ Comment=portable NeoGeo Emulator
Exec=gngeo
Icon=gngeo
Terminal=false
-Categories=Game;Emulator
+Categories=Game;Emulator;