summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4db639325ce6..fb72098dc2eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,14 @@
pkgbase = gnofract4d
pkgdesc = Create beautiful fractal images
pkgver = 4.3
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/fract4d/gnofract4d
arch = any
license = BSD
checkdepends = python-pytest
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = gtk3
depends = libjpeg
diff --git a/PKGBUILD b/PKGBUILD
index 1d04b5c976a4..ecc04a8883ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,21 @@
pkgname=gnofract4d
pkgver=4.3
-pkgrel=3
-pkgdesc="Create beautiful fractal images"
-arch=('any')
-url="https://github.com/fract4d/gnofract4d"
-license=('BSD')
-depends=('gtk3' 'libjpeg' 'libpng' 'python-cairo' 'python-gobject')
-makedepends=('python-setuptools')
+pkgrel=4
+pkgdesc='Create beautiful fractal images'
+arch=(any)
+url=https://github.com/fract4d/gnofract4d
+license=(BSD)
+depends=(gtk3 libjpeg libpng python-cairo python-gobject)
+makedepends=(python-build python-installer python-wheel python-setuptools)
optdepends=('ffmpeg: to create videos')
-checkdepends=('python-pytest')
+checkdepends=(python-pytest)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('8fb22fd626b3452957802abe9fba311d495481ddf91a2ecf8a41fc38377639e3')
build() {
cd $pkgname-$pkgver
- ./setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -30,7 +30,7 @@ check() {
package() {
cd $pkgname-$pkgver
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 doc/$pkgname.1 -t "$pkgdir/usr/share/man/man1"
- ./setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
-