summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--61-gnome-bluetooth-rfkill.rules7
-rw-r--r--PKGBUILD39
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6054fb143258
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = gnome-bluetooth-pantheon
+ pkgdesc = The GNOME Bluetooth Subsystem (with elementary OS patches)
+ pkgver = 3.26.1+3+r2.63f0bf3f4
+ pkgrel = 1
+ url = https://wiki.gnome.org/Projects/GnomeBluetooth
+ arch = x86_64
+ groups = pantheon
+ license = GPL
+ license = LGPL
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = docbook-xsl
+ makedepends = git
+ makedepends = systemd
+ makedepends = meson
+ depends = gtk3
+ depends = libnotify
+ depends = bluez
+ depends = libcanberra
+ depends = libsystemd
+ depends = pulseaudio-bluetooth
+ provides = gnome-bluetooth=3.26.1+3+r2.63f0bf3f4
+ conflicts = gnome-bluetooth
+ source = git+https://github.com/elementary/os-patches.git#branch=gnome-bluetooth-bionic-patched
+ source = 61-gnome-bluetooth-rfkill.rules
+ sha256sums = SKIP
+ sha256sums = 8dd2d3637f380a89e72f65e6c8021e994ccbdc645f1a1b1dbffe74ac9f061f53
+
+pkgname = gnome-bluetooth-pantheon
+
diff --git a/61-gnome-bluetooth-rfkill.rules b/61-gnome-bluetooth-rfkill.rules
new file mode 100644
index 000000000000..d7d9650dc7b6
--- /dev/null
+++ b/61-gnome-bluetooth-rfkill.rules
@@ -0,0 +1,7 @@
+# Get access to /dev/rfkill for users
+# See https://bugzilla.redhat.com/show_bug.cgi?id=514798
+#
+# Simplified by Kay Sievers
+# https://bugzilla.redhat.com/show_bug.cgi?id=733326
+
+KERNEL=="rfkill", SUBSYSTEM=="misc", TAG+="uaccess"
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fedfd730468c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Que Quotion <quequotion@bugmenot.com>
+# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=gnome-bluetooth-pantheon
+pkgver=3.26.1+3+r2.63f0bf3f4
+pkgrel=1
+pkgdesc="The GNOME Bluetooth Subsystem (with elementary OS patches)"
+url="https://wiki.gnome.org/Projects/GnomeBluetooth"
+arch=(x86_64)
+license=(GPL LGPL)
+depends=(gtk3 libnotify bluez libcanberra libsystemd pulseaudio-bluetooth)
+makedepends=(gobject-introspection gtk-doc docbook-xsl git systemd meson)
+groups=(pantheon)
+provides=(gnome-bluetooth="${pkgver}")
+conflicts=(gnome-bluetooth)
+source=("git+https://github.com/elementary/os-patches.git#branch=gnome-bluetooth-bionic-patched"
+ 61-gnome-bluetooth-rfkill.rules)
+sha256sums=('SKIP'
+ '8dd2d3637f380a89e72f65e6c8021e994ccbdc645f1a1b1dbffe74ac9f061f53')
+
+pkgver() {
+ cd "os-patches"
+
+ printf "3.26.1+3+r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ arch-meson "os-patches" build -D gtk_doc=true -D icon_update=false
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dt "$pkgdir/usr/lib/udev/rules.d" -m644 61-gnome-bluetooth-rfkill.rules
+}