summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 39 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0d5e8308aeb4..25ee50d83ad5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = gnome-chess-git
pkgdesc = Play the classic two-player boardgame of chess
- pkgver = 3.37.2+3+gaf4e19f
+ pkgver = 43.2+6+g389df74
pkgrel = 1
url = https://wiki.gnome.org/Apps/Chess
arch = x86_64
+ groups = gnome-extra
+ groups = gnome-extra-git
license = GPL
- makedepends = gobject-introspection
- makedepends = yelp-tools
- makedepends = appstream-glib
- makedepends = vala
makedepends = git
+ makedepends = gobject-introspection
makedepends = meson
- depends = gtk3
+ makedepends = vala
+ makedepends = yelp-tools
+ depends = gtk4
+ depends = libadwaita
depends = librsvg
optdepends = gnuchess: Play against computer
provides = gnome-chess
@@ -20,4 +22,3 @@ pkgbase = gnome-chess-git
sha512sums = SKIP
pkgname = gnome-chess-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c538f3dfa529..0db2b5d24c82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,44 @@
-pkgname=gnome-chess-git
+# Maintainer: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
+
_pkgname=gnome-chess
-pkgver=3.37.2+3+gaf4e19f
+pkgname="${_pkgname}-git"
+pkgver=43.2+6+g389df74
pkgrel=1
pkgdesc="Play the classic two-player boardgame of chess"
url="https://wiki.gnome.org/Apps/Chess"
arch=(x86_64)
license=(GPL)
-depends=('gtk3' 'librsvg')
-makedepends=('gobject-introspection' 'yelp-tools' 'appstream-glib' 'vala' 'git' 'meson')
-optdepends=('gnuchess: Play against computer')
-provides=('gnome-chess')
-conflicts=('gnome-chess')
-source=("git+https://gitlab.gnome.org/GNOME/gnome-chess.git")
+depends=(
+ gtk4
+ libadwaita
+ librsvg
+)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+ yelp-tools
+)
+optdepends=(
+ 'gnuchess: Play against computer')
+groups=(gnome-extra gnome-extra-git)
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://gitlab.gnome.org/GNOME/${_pkgname}.git")
sha512sums=('SKIP')
pkgver() {
- cd $_pkgname
+ cd "${_pkgname}"
git describe --tags | sed 's/-/+/g'
}
+prepare() {
+ cd "${_pkgname}"
+}
+
build() {
- arch-meson $_pkgname build
+ arch-meson "${_pkgname}" build
meson compile -C build
}
@@ -29,5 +47,7 @@ check() {
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir="${pkgdir}"
}
+
+# vim:set sw=2 sts=-1 et: