summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--notify-notification-close.patch13
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1202e18de9c9..939588f33380 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-settings-daemon-elementary
pkgdesc = GNOME Settings Daemon (with elementary OS patches)
pkgver = 3.28.1+0ubuntu1+r3.6975d1c25
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.gnome.org/GNOME/gnome-settings-daemon
arch = i686
arch = x86_64
@@ -40,8 +40,10 @@ pkgbase = gnome-settings-daemon-elementary
conflicts = gnome-settings-daemon-ubuntu
source = git+https://github.com/elementary/os-patches.git#branch=gnome-settings-daemon-bionic-patched
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git/
+ source = notify-notification-close.patch
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = c17fefa6e70ffbc901c247013f5296738a227fa192027cd5e7e8e086e6bda04773bcd6b61a06a4d2c1b030385ca91d7d02a7fec89eed64eaab02f62906e6a725
pkgname = gnome-settings-daemon-elementary
diff --git a/PKGBUILD b/PKGBUILD
index 40afd35609b8..461a5fe09fee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=gnome-settings-daemon-elementary
pkgver=3.28.1+0ubuntu1+r3.6975d1c25
-pkgrel=1
+pkgrel=2
pkgdesc="GNOME Settings Daemon (with elementary OS patches)"
url="https://gitlab.gnome.org/GNOME/gnome-settings-daemon"
arch=('i686' 'x86_64')
@@ -20,9 +20,11 @@ groups=(pantheon)
provides=(gnome-settings-daemon{,-ubuntu}="${pkgver}")
conflicts=(gnome-settings-daemon{,-ubuntu})
source=("git+https://github.com/elementary/os-patches.git#branch=gnome-settings-daemon-bionic-patched"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git/")
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git/"
+ "notify-notification-close.patch")
sha512sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'c17fefa6e70ffbc901c247013f5296738a227fa192027cd5e7e8e086e6bda04773bcd6b61a06a4d2c1b030385ca91d7d02a7fec89eed64eaab02f62906e6a725')
pkgver() {
cd "os-patches"
@@ -32,6 +34,8 @@ pkgver() {
prepare() {
cd "os-patches"
+ patch -Np2 < ../notify-notification-close.patch
+
git submodule init
git config --local submodule."subprojects/gvc".url "${srcdir}/libgnome-volume-control"
git submodule update
diff --git a/notify-notification-close.patch b/notify-notification-close.patch
new file mode 100644
index 000000000000..c583ddf8d45e
--- /dev/null
+++ b/notify-notification-close.patch
@@ -0,0 +1,13 @@
+--- src/os-patches/plugins/housekeeping/gsd-disk-space.c~ 2018-09-29 16:07:04.972842146 +0900
++++ src/os-patches/plugins/housekeeping/gsd-disk-space.c 2018-09-29 16:09:47.679514729 +0900
+@@ -1017,7 +1017,9 @@
+ g_clear_object (&ldsm_monitor);
+ g_clear_object (&settings);
+ g_clear_object (&privacy_settings);
+- g_clear_pointer (&notification, notify_notification_close);
++ /* NotifyNotification::closed callback will drop reference */
++ if (notification != NULL)
++ notify_notification_close (notification, NULL);
+ g_slist_free_full (ignore_paths, g_free);
+ ignore_paths = NULL;
+ }