summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
-rwxr-xr-x[-rw-r--r--]gnome-shell-extension-applications-overview-tooltip.install32
2 files changed, 15 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71f1911fe94f..61ad63922196 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Christian Schendel <doppelhelix at gmail dot com>
pkgname=gnome-shell-extension-applications-overview-tooltip-git
pkgver=10.r2.g2e81270
-pkgrel=4
+pkgrel=5
pkgdesc="Shows a tooltip over applications icons on applications overview"
arch=(any)
url="https://github.com/RaphaelRochet/applications-overview-tooltip"
diff --git a/gnome-shell-extension-applications-overview-tooltip.install b/gnome-shell-extension-applications-overview-tooltip.install
index 19bbbb3c8b72..36082690278e 100644..100755
--- a/gnome-shell-extension-applications-overview-tooltip.install
+++ b/gnome-shell-extension-applications-overview-tooltip.install
@@ -1,24 +1,20 @@
-post_install() {
- instructions_install
-}
-
-post_upgrade() {
- instructions_upgrade
-}
-
-instructions_install() {
- cat <<-EOT
+# Colored makepkg-like functions
- Restart GNOME Shell ([Alt]+[F2], r).
- Activate the extension with gnome-tweak-tool.
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
- EOT
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
}
-instructions_upgrade() {
- cat <<-EOT
-
- Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+post_install() {
+ note "Restart GNOME Shell ([Alt]+[F2], r)."
+ note "Activate the extension with gnome-tweak-tool."
+}
- EOT
+post_upgrade() {
+ note "Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension."
}
+