summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 4 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a57cfd008252..c752bd362d1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,8 @@ pkgbase = gnome-shell-extension-applications-overview-tooltip-git
install = gnome-shell-extension-applications-overview-tooltip.install
arch = any
license = GPL
+ makedepends = git
+ makedepends = glib2
depends = gnome-shell>=3.38
provides = gnome-shell-extension-applications-overview-tooltip
conflicts = gnome-shell-extension-applications-overview-tooltip
diff --git a/PKGBUILD b/PKGBUILD
index 8641e91ca32e..60459870b3e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,6 +9,7 @@ url="https://github.com/RaphaelRochet/applications-overview-tooltip"
install=${pkgname%-git}.install
license=('GPL')
depends=('gnome-shell>=3.38')
+makedepends=('git' 'glib2')
conflicts=("${pkgname%-git}")
provides=(${pkgname%-git})
source=("${pkgname%-git}::git+https://github.com/RaphaelRochet/applications-overview-tooltip.git#commit=$_commit")
@@ -26,7 +27,7 @@ package() {
install -d "${pkgdir}/usr/share/gnome-shell/extensions/"
mv ${pkgname%-git} ${_uuid}
cp -r "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
- #rebuild compiled schemas if missimg
+ #rebuild compiled schemas if missing
if [[ ! -f "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas/gschemas.compiled" ]]; then
glib-compile-schemas ${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas
fi