summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD44
3 files changed, 36 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7518b7bbcb2..9f7a215542fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = gnome-shell-extension-blyr
- pkgdesc = Apply a Blur Effect to GNOME Shell UI elements
+ pkgdesc = A GNOME extension that applies a blur effect to GNOME Shell UI elements.
pkgver = 8
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/yozoon/gnome-shell-extension-blyr
arch = any
- license = GPL
+ license = GPL2
makedepends = unzip
depends = gnome-shell>=3.34
- optdepends = clutter-gtk: configuring blyr
+ optdepends = clutter-gtk: required to configure GNOME Shell extensions.
noextract = blyr@yozoon.dev.gmail.com.zip
source = https://github.com/yozoon/gnome-shell-extension-blyr/releases/download/v8/blyr@yozoon.dev.gmail.com.zip
b2sums = bed0fc8c61585248312bcbb0dcf4ae282d2c79aef58df446660060476d6e66446d52409ca9b0d7d64807ebb1ee2e046572f97d82d74fcb203f68935a27ff55ed
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c800fbfcd445
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+*.zip
+
+*.pkg.*
diff --git a/PKGBUILD b/PKGBUILD
index 4c55ec8aaae2..86d90b62089d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,40 @@
-# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
+# Maintainer: Diab Neiroukh <lazerl0rd at thezest dot dev>
pkgname="gnome-shell-extension-blyr"
pkgver=8
-pkgrel=1
+pkgrel=2
epoch=1
-pkgdesc="Apply a Blur Effect to GNOME Shell UI elements"
-arch=(any)
+arch=("any")
+pkgdesc="A GNOME extension that applies a blur effect to GNOME Shell UI elements."
url="https://github.com/yozoon/gnome-shell-extension-blyr"
-license=(GPL)
-depends=('gnome-shell>=3.34')
-optdepends=('clutter-gtk: configuring blyr')
-makedepends=(unzip)
-source=(https://github.com/yozoon/gnome-shell-extension-blyr/releases/download/v$pkgver/blyr@yozoon.dev.gmail.com.zip)
-noextract=(blyr@yozoon.dev.gmail.com.zip)
-b2sums=('bed0fc8c61585248312bcbb0dcf4ae282d2c79aef58df446660060476d6e66446d52409ca9b0d7d64807ebb1ee2e046572f97d82d74fcb203f68935a27ff55ed')
+license=("GPL2")
+depends=(
+ "gnome-shell>=3.34"
+)
+makedepends=(
+ "unzip"
+)
+optdepends=(
+ "clutter-gtk: required to configure GNOME Shell extensions."
+)
+source=(
+ "https://github.com/yozoon/gnome-shell-extension-blyr/releases/download/v$pkgver/blyr@yozoon.dev.gmail.com.zip"
+)
+noextract=(
+ "blyr@yozoon.dev.gmail.com.zip"
+)
+b2sums=(
+ "bed0fc8c61585248312bcbb0dcf4ae282d2c79aef58df446660060476d6e66446d52409ca9b0d7d64807ebb1ee2e046572f97d82d74fcb203f68935a27ff55ed"
+)
prepare()
{
- install -d "gnome-shell-extension-blyr"
- unzip "blyr@yozoon.dev.gmail.com.zip" -d "gnome-shell-extension-blyr"
+ install -d "gnome-shell-extension-blyr"
+ unzip "blyr@yozoon.dev.gmail.com.zip" -d "gnome-shell-extension-blyr"
}
package()
{
- local _uuid="blyr@yozoon.dev.gmail.com"
-
- install -d "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
- cp -r "gnome-shell-extension-blyr/"* "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/blyr@yozoon.dev.gmail.com"
+ cp -r "gnome-shell-extension-blyr/"* "$pkgdir/usr/share/gnome-shell/extensions/blyr@yozoon.dev.gmail.com"
}