summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD29
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e0df3438d10..d8d7e44853bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-caffeine
pkgdesc = Extension for GNOME shell to disable screensaver and auto suspend
pkgver = 50
- pkgrel = 3
+ pkgrel = 4
epoch = 1
url = https://github.com/eonpatapon/gnome-shell-extension-caffeine
arch = any
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..40ff3d8eb413
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+/*.tar.gz
+/*.log
diff --git a/PKGBUILD b/PKGBUILD
index 87faccbadc8a..c26a8ef5f985 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Robin Candau <antiz@archlinux.org>
+# Maintainer: Sebastian Wiesner <sebastian@swsnr.de>
+# Contributor: Robin Candau <antiz@archlinux.org>
pkgname=gnome-shell-extension-caffeine
-_uuid=caffeine@patapon.info
pkgver=50
-pkgrel=3
+pkgrel=4
epoch=1
pkgdesc='Extension for GNOME shell to disable screensaver and auto suspend'
arch=('any')
@@ -20,8 +20,27 @@ build() {
package() {
cd "${pkgname}-${pkgver}"
- install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- bsdtar -xvf "${_uuid}.zip" -C "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}" --no-same-owner
+
+ local _uuid=caffeine@patapon.info
+
+ install -d \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}" \
+ "${pkgdir}/usr/share/glib-2.0/"
+
+ # Extract extension artifact to system extension directory.
+ bsdtar -xvf "${_uuid}.zip" \
+ -C "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}" \
+ --no-same-owner
+
+ # Move settings schema to system schema dir and remove compiled schema (a
+ # pacman hook generates those)
+ mv "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/schemas" \
+ "${pkgdir}/usr/share/glib-2.0/"
+ rm "${pkgdir}/usr/share/glib-2.0/schemas/gschemas.compiled"
+
+ # Move local to system locale directory
+ mv "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/locale" \
+ "${pkgdir}/usr/share"
install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}