summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22e520bc15df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-draw-on-your-screen-git
+ pkgdesc = A drawing extension for GNOME Shell.
+ pkgver = v4.r0.g71c2309
+ pkgrel = 1
+ url = https://framagit.org/abakkk/DrawOnYourScreen
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = gnome-shell
+ conflicts = gnome-shell-extension-draw-on-your-screen
+ source = git+https://framagit.org/abakkk/DrawOnYourScreen.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-draw-on-your-screen-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2455934e6161
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
+
+pkgname=gnome-shell-extension-draw-on-your-screen-git
+_pkgname=DrawOnYourScreen
+pkgver=v4.r0.g71c2309
+pkgrel=1
+pkgdesc="A drawing extension for GNOME Shell."
+arch=('any')
+url="https://framagit.org/abakkk/DrawOnYourScreen"
+license=('GPLv2')
+conflicts=('gnome-shell-extension-draw-on-your-screen')
+depends=('gnome-shell')
+makedepends=('git')
+source=('git+https://framagit.org/abakkk/DrawOnYourScreen.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ _extid='drawOnYourScreen@abakkk.framagit.org'
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cp -af "${_pkgname}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ mv "${pkgdir}/usr/share/gnome-shell/extensions/${_pkgname}" "${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+ msg2 "Start drawing with Super+Alt+D. Then save your beautiful work by taking a screenshot."
+}