summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..135adec3de54
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-floatingdock-git
+ pkgdesc = Move dock anywhere on the desktop
+ pkgver = r97.5906027
+ pkgrel = 1
+ url = https://github.com/sunwxg/gnome-shell-extension-floatingDock
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-floatingdock-git::git+https://github.com/sunwxg/gnome-shell-extension-floatingDock.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-floatingdock-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bc3a603860f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Butui Hu <hot123tea123@gmail.com>
+# Contributor: Thanos Apostolou <thanosapostolou@outlook.com>
+
+pkgname=gnome-shell-extension-floatingdock-git
+pkgver=r97.5906027
+pkgrel=1
+pkgdesc='Move dock anywhere on the desktop'
+arch=('any')
+url='https://github.com/sunwxg/gnome-shell-extension-floatingDock'
+license=('MIT')
+depends=(
+ gnome-shell
+)
+makedepends=(git)
+source=(
+ "${pkgname}::git+https://github.com/sunwxg/gnome-shell-extension-floatingDock.git"
+)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -r floatingDock@sun.wxg@gmail.com "${pkgdir}/usr/share/gnome-shell/extensions"
+ install -Dm644 "${srcdir}/${pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+# vim:set ts=2 sw=2 et:
+