summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95d84a9d7f62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-frequency-boost-switch-git
+ pkgdesc = Add a toggle to enable/disable CPU frequency boost in Gnome Power Profiles menu.
+ pkgver = r5.2bce622
+ pkgrel = 1
+ url = https://gitlab.com/metal03326/gnome-frequency-boost-switch
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = zip
+ depends = gnome-shell>=1.41
+ provides = gnome-shell-extension-frequency-boost-switch
+ conflicts = gnome-shell-extension-frequency-boost-switch
+ source = git+https://gitlab.com/metal03326/gnome-frequency-boost-switch.git
+ b2sums = SKIP
+
+pkgname = gnome-shell-extension-frequency-boost-switch-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bd866de3cd1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
+
+pkgname=gnome-shell-extension-frequency-boost-switch-git
+_pkgname=gnome-frequency-boost-switch
+pkgver=r5.2bce622
+pkgrel=1
+pkgdesc="Add a toggle to enable/disable CPU frequency boost in Gnome Power Profiles menu."
+arch=('any')
+url="https://gitlab.com/metal03326/gnome-frequency-boost-switch"
+license=('GPL3')
+depends=('gnome-shell>=1.41')
+makedepends=('git' 'zip')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$_pkgname"
+
+ make build
+}
+
+package() {
+ cd "$_pkgname"
+
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' src/metadata.json)
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
+ bsdtar -xvf ${uuid}.shell-extension.zip -C "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
+}