summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--system-wide-gschema-fix.patch41
3 files changed, 43 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0cc63c742bef..8fbc267a8848 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-extension-jiggle
pkgdesc = Gnome extension that highlights the cursor position when the mouse is moved rapidly.
pkgver = 8+r38+g436d1cf
- pkgrel = 9
+ pkgrel = 10
url = https://github.com/jeffchannell/jiggle
arch = any
groups = gnome-shell-extensions
diff --git a/PKGBUILD b/PKGBUILD
index d03724ddd418..342afcc65248 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ _extname=jiggle
_uuid=jiggle@jeffchannell.com
pkgname=gnome-shell-extension-jiggle
pkgver=8+r38+g436d1cf
-pkgrel=9
+pkgrel=10
pkgdesc='Gnome extension that highlights the cursor position when the mouse is moved rapidly.'
arch=('any')
url='https://github.com/jeffchannell/jiggle'
diff --git a/system-wide-gschema-fix.patch b/system-wide-gschema-fix.patch
new file mode 100644
index 000000000000..42c416f50db4
--- /dev/null
+++ b/system-wide-gschema-fix.patch
@@ -0,0 +1,41 @@
+From d64c6ca52de7c29c4df55b00d8ef23dd32d7b2b7 Mon Sep 17 00:00:00 2001
+From: Ewout van Mansom <ewout@vanmansom.name>
+Date: Fri, 2 Dec 2022 22:16:09 +0100
+Subject: [PATCH] support system-wide gschema
+
+---
+ settings.js | 22 ++++++++++++++--------
+ 1 file changed, 14 insertions(+), 8 deletions(-)
+
+diff --git a/settings.js b/settings.js
+index d07ca64..1465b31 100644
+--- a/settings.js
++++ b/settings.js
+@@ -12,13 +12,19 @@ const Me = ExtensionUtils.getCurrentExtension();
+ */
+ function settings()
+ {
+- let gschema = Gio.SettingsSchemaSource.new_from_directory(
+- Me.dir.get_child('schemas').get_path(),
+- Gio.SettingsSchemaSource.get_default(),
+- false
+- );
++ // first try developer friendly embedded schema
++ try {
++ let gschema = Gio.SettingsSchemaSource.new_from_directory(
++ Me.dir.get_child('schemas').get_path(),
++ Gio.SettingsSchemaSource.get_default(),
++ false
++ );
++ return new Gio.Settings({
++ settings_schema: gschema.lookup('org.gnome.shell.extensions.jiggle', true)
++ });
++ } catch (e) {
++ // now try system one below
++ }
+
+- return new Gio.Settings({
+- settings_schema: gschema.lookup('org.gnome.shell.extensions.jiggle', true)
+- });
++ return new Gio.Settings({schema_id: 'org.gnome.shell.extensions.jiggle'});
+ }