summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b25a5f79df11..1f751f148f43 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = gnome-shell-extension-openweather-git
pkgdesc = Gnome shell extension for displaying weather information
- pkgver = 121.r11.g22859b4
+ pkgver = r1268.9117377
pkgrel = 1
- url = https://gitlab.com/skrewball/openweather
+ epoch = 1
+ url = https://github.com/toppk/gnome-shell-extension-openweather
arch = any
license = GPL3
makedepends = git
@@ -10,7 +11,7 @@ pkgbase = gnome-shell-extension-openweather-git
depends = gnome-shell
provides = gnome-shell-extension-weather-git
conflicts = gnome-shell-extension-weather-git
- source = openweather::git+https://gitlab.com/skrewball/openweather.git
+ source = git+https://github.com/toppk/gnome-shell-extension-openweather.git
sha256sums = SKIP
pkgname = gnome-shell-extension-openweather-git
diff --git a/PKGBUILD b/PKGBUILD
index 1f0392511d1a..adc006cea0cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@
# Contributor: jtts
# Contributor: Christian METZLER <neroth@xeked.com>
pkgname=gnome-shell-extension-openweather-git
-_pkgbase=openweather
-pkgver=121.r11.g22859b4
+_pkgbase=gnome-shell-extension-openweather
+pkgver=r1268.9117377
pkgrel=1
+epoch=1
pkgdesc="Gnome shell extension for displaying weather information"
arch=(any)
url="https://github.com/toppk/gnome-shell-extension-openweather"
@@ -19,7 +20,8 @@ sha256sums=('SKIP')
pkgver() {
cd "$_pkgbase"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ #git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {