summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15ad11937587..25b7f96748ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gnome-shell-extension-shutdowntimer
pkgdesc = Shutdown your device after a specific time. This extension adds a submenu to the status area.
- pkgver = 21
+ pkgver = v30
pkgrel = 1
- url = https://github.com/neumann89/ShutdownTimer
+ url = https://github.com/neumann-d/ShutdownTimer
arch = any
license = unknow
depends = gnome-shell
- source = git+https://github.com/neumann89/ShutdownTimer.git
+ conflicts = gnome-shell-extension-shutdowntimer-git
+ source = git+https://github.com/neumann-d/ShutdownTimer.git
sha256sums = SKIP
pkgname = gnome-shell-extension-shutdowntimer
-
diff --git a/PKGBUILD b/PKGBUILD
index 0e7901f8c52b..a927b95d99cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,24 @@
# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
pkgname=gnome-shell-extension-shutdowntimer
-pkgver=21
+pkgver=v30
pkgrel=1
pkgdesc="Shutdown your device after a specific time. This extension adds a submenu to the status area."
arch=('any')
-url="https://github.com/neumann89/ShutdownTimer"
+url="https://github.com/neumann-d/ShutdownTimer"
license=('unknow')
+conflicts=('gnome-shell-extension-shutdowntimer-git')
depends=('gnome-shell')
-source=("git+https://github.com/neumann89/ShutdownTimer.git")
+source=("git+https://github.com/neumann-d/ShutdownTimer.git")
sha256sums=('SKIP')
+pkgver() {
+ cd $_pkgname
+ git describe --always --tags | tr '-' '_'
+}
+
package() {
- cd "${srcdir}/ShutdownTimer"
- mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
- cp -af "ShutdownTimer@neumann" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cd "${srcdir}/ShutdownTimer"
+ mkdir -p "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cp -af "ShutdownTimer@neumann" "${pkgdir}/usr/share/gnome-shell/extensions/"
}