summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD49
-rw-r--r--gnome-shell-google-calendar-git.desktop7
-rw-r--r--gnome-shell-google-calendar-git.install19
-rw-r--r--gnome-shell-google-calendar-git.sh10
5 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eeb73da1c8f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnome-shell-google-calendar-git
+ pkgdesc = A D-Bus service that fetches events from Google Calendar and makes theme available for GNOME Shell to display.
+ pkgver = 20140817
+ pkgrel = 1
+ url = https://github.com/hashken/gnome-shell-google-calendar
+ install = gnome-shell-google-calendar-git.install
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = python2-dbus
+ depends = gnome-shell
+ depends = pygtk
+ depends = python2-iso8601
+ depends = python2-gdata
+ source = gnome-shell-google-calendar-git.desktop
+ source = gnome-shell-google-calendar-git.sh
+ md5sums = 7da5e2796cf090cf4c7b0ddf3cd96bc0
+ md5sums = cbcf0c1f212a4916b030828467842d7f
+
+pkgname = gnome-shell-google-calendar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a3e640daaa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Karthik K <hashken.distro@gmail.com>
+
+pkgname=gnome-shell-google-calendar-git
+pkgver=20140817
+pkgrel=1
+pkgdesc="A D-Bus service that fetches events from Google Calendar and makes theme available for GNOME Shell to display."
+arch=('any')
+url="https://github.com/hashken/gnome-shell-google-calendar"
+license=('unknown')
+makedepends=('git')
+depends=('python2-dbus' 'gnome-shell' 'pygtk' 'python2-iso8601' 'python2-gdata')
+install="${pkgname}.install"
+source=("${pkgname}.desktop"
+ "${pkgname}.sh")
+md5sums=('7da5e2796cf090cf4c7b0ddf3cd96bc0'
+ 'cbcf0c1f212a4916b030828467842d7f')
+
+_gitroot="git://github.com/hashken/gnome-shell-google-calendar.git"
+_gitname="gnome-shell-google-calendar"
+
+build() {
+ cd ${srcdir}
+ msg "Connecting to github GIT server...."
+
+ if [ -d ${srcdir}/${_gitname} ] ; then
+ cd ${_gitname} && git pull origin
+ msg "The local files are updated."
+ else
+ git clone --depth=1 ${_gitroot}
+ fi
+
+ msg "GIT checkout done or server timeout"
+}
+
+package() {
+ # install pyfiles
+ mkdir -p "${pkgdir}/usr/share/gnome-shell-google-calendar"
+ install -Dm 0755 "${srcdir}/${_gitname}/gnome-shell-google-calendar.py" "${pkgdir}/usr/share/gnome-shell-google-calendar/gnome-shell-google-calendar.py"
+ install -Dm 0755 "${srcdir}/${_gitname}/oauth.py" "${pkgdir}/usr/share/gnome-shell-google-calendar/oauth.py"
+ install -Dm 0755 "${srcdir}/${_gitname}/config.py" "${pkgdir}/usr/share/gnome-shell-google-calendar/config.py"
+ install -Dm 0755 "${srcdir}/${_gitname}/keyring.py" "${pkgdir}/usr/share/gnome-shell-google-calendar/keyring.py"
+
+ # autostart
+ mkdir -p "${pkgdir}/etc/xdg/autostart"
+ install -Dm 0644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/etc/xdg/autostart/gnome-shell-google-calendar.desktop"
+ install -Dm 0755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/share/gnome-shell-google-calendar/gnome-shell-google-calendar-startup.sh"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-google-calendar-git.desktop b/gnome-shell-google-calendar-git.desktop
new file mode 100644
index 000000000000..6ee15ecb3374
--- /dev/null
+++ b/gnome-shell-google-calendar-git.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Exec=/usr/share/gnome-shell-google-calendar/gnome-shell-google-calendar-startup.sh
+Hidden=false
+X-GNOME-Autostart-enabled=true
+Name=gnome-shell-google-calendar
+Comment=An attempt to integrate google calendar into gnome-shell.
diff --git a/gnome-shell-google-calendar-git.install b/gnome-shell-google-calendar-git.install
new file mode 100644
index 000000000000..01bc3a75f0cc
--- /dev/null
+++ b/gnome-shell-google-calendar-git.install
@@ -0,0 +1,19 @@
+post_install() {
+ ln -s "/usr/share/gnome-shell-google-calendar/gnome-shell-google-calendar.py" "/usr/bin/gnome-shell-google-calendar"
+ chmod 755 "/usr/bin/gnome-shell-google-calendar"
+ echo "Run manually first time to identify vs gnome-keyring or set anual details at ~/.config/gnome-shell-google-calendar/config.json"
+}
+
+post_remove() {
+ rm "/usr/bin/gnome-shell-google-calendar"
+}
+
+post_upgrade() {
+ if [ ! -f "/usr/bin/gnome-shell-google-calendar" ];
+ then
+ ln -s "/usr/share/gnome-shell-google-calendar/gnome-shell-google-calendar.py" "/usr/bin/gnome-shell-google-calendar"
+ chmod 755 "/usr/bin/gnome-shell-google-calendar"
+ fi
+ echo "If you are using gnome-shell-google-calendar behind a proxy, then configure the file /usr/share/gnome-shell-google-calendar/gnome-shell-google-calendar-startup.sh."
+ echo "Run manually first time to identify vs gnome-keyring or set manual details at ~/.config/gnome-shell-google-calendar/config.json"
+}
diff --git a/gnome-shell-google-calendar-git.sh b/gnome-shell-google-calendar-git.sh
new file mode 100644
index 000000000000..87bfaeab33f2
--- /dev/null
+++ b/gnome-shell-google-calendar-git.sh
@@ -0,0 +1,10 @@
+#!/bin/bash
+# when network is slow to connect, google calendar acts up...
+# ...so we delay its execution.
+
+#export http_proxy=""
+#export https_proxy=""
+#export proxy_username=""
+#export proxy_password=""
+sleep 20
+/usr/bin/gnome-shell-google-calendar