summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
2 files changed, 4 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e4efd6a1a7d..707401501c5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -80,3 +80,5 @@ pkgname = gnome-shell-performance
pkgname = gnome-shell-performance-docs
pkgdesc = Next generation desktop shell | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync (API documentation)
depends =
+ provides = gnome-shell-docs
+ conflicts = gnome-shell-docs
diff --git a/PKGBUILD b/PKGBUILD
index 6f92fe7ad9c2..fedeffb19da8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -217,6 +217,8 @@ package_gnome-shell-performance() {
if ! [ -n "$_disable_docs" ]; then
package_gnome-shell-performance-docs() {
pkgdesc+=" (API documentation)"
+ provides=(gnome-shell-docs)
+ conflicts=(gnome-shell-docs)
depends=()
mv doc/* "$pkgdir"