summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--276.diff65
-rw-r--r--PKGBUILD65
3 files changed, 16 insertions, 126 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70dbc97147ef..d1a3c5ca9139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches
- pkgver = 3.30.2+4
- pkgrel = 7
+ pkgver = 3.32.0
+ pkgrel = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
groups = gnome
@@ -34,16 +34,12 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.30.2+4
+ provides = gnome-shell=3.32.0
conflicts = gnome-shell
- source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=2a36bf52cb61ac1a015bc2150807a8d47c7155e4
+ source = gnome-shell-performance::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=47915f8c1117470e5351a8ec4e4bdac5e683498d
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
- source = 276.diff
- source = https://gitlab.gnome.org/GNOME/gnome-shell/raw/e26de6865dc6bed3af45355aeb4060e4e0f854d7/js/ui/workspaceThumbnail.js
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = aee12ef68be36cf8f87e67e00ebd620fe2aa3aac234a16a0ab2b65db1e1fbfdc
- sha256sums = ad16e4defb7e93ed26e663da6e19ec26dd0eeafbc86608598e19278360d23fdd
pkgname = gnome-shell-performance
diff --git a/276.diff b/276.diff
deleted file mode 100644
index 9dcdc88fcbc9..000000000000
--- a/276.diff
+++ /dev/null
@@ -1,65 +0,0 @@
-diff --git a/js/ui/padOsd.js b/js/ui/padOsd.js
-index 48219026c..9da51c4f2 100644
---- a/js/ui/padOsd.js
-+++ b/js/ui/padOsd.js
-@@ -638,7 +638,7 @@ var PadOsd = new Lang.Class({
- this._settings = settings;
- this._imagePath = imagePath;
- this._editionMode = editionMode;
-- this._capturedEventId = global.stage.connect('captured-event', this._onCapturedEvent.bind(this));
-+ this._capturedEventId = global.stage.connect('captured-event::nonmotion', this._onCapturedEvent.bind(this));
- this._padChooser = null;
-
- let deviceManager = Clutter.DeviceManager.get_default();
-diff --git a/js/ui/panel.js b/js/ui/panel.js
-index 66588f9c1..6bbf7bc06 100644
---- a/js/ui/panel.js
-+++ b/js/ui/panel.js
-@@ -418,7 +418,7 @@ var ActivitiesButton = new Lang.Class({
-
- this.actor.label_actor = this._label;
-
-- this.actor.connect('captured-event', this._onCapturedEvent.bind(this));
-+ this.actor.connect('captured-event::nonmotion', this._onCapturedEvent.bind(this));
- this.actor.connect_after('key-release-event', this._onKeyRelease.bind(this));
-
- Main.overview.connect('showing', () => {
-diff --git a/js/ui/status/system.js b/js/ui/status/system.js
-index c695f37be..1c61ed87e 100644
---- a/js/ui/status/system.js
-+++ b/js/ui/status/system.js
-@@ -32,7 +32,7 @@ var AltSwitcher = new Lang.Class({
- this._alternate.connect('clicked',
- () => { this._clickAction.release(); });
-
-- this._capturedEventId = global.stage.connect('captured-event', this._onCapturedEvent.bind(this));
-+ this._capturedEventId = global.stage.connect('captured-event::nonmotion', this._onCapturedEvent.bind(this));
-
- this._flipped = false;
-
-diff --git a/js/ui/viewSelector.js b/js/ui/viewSelector.js
-index 6a235eccd..4a747c834 100644
---- a/js/ui/viewSelector.js
-+++ b/js/ui/viewSelector.js
-@@ -57,7 +57,7 @@ var TouchpadShowOverviewAction = new Lang.Class({
- Name: 'TouchpadShowOverviewAction',
-
- _init(actor) {
-- actor.connect('captured-event', this._handleEvent.bind(this));
-+ actor.connect('captured-event::nonmotion', this._handleEvent.bind(this));
- },
-
- _handleEvent(actor, event) {
-diff --git a/js/ui/windowManager.js b/js/ui/windowManager.js
-index adfee93a9..771391825 100644
---- a/js/ui/windowManager.js
-+++ b/js/ui/windowManager.js
-@@ -477,7 +477,7 @@ var TouchpadWorkspaceSwitchAction = new Lang.Class({
- _init(actor) {
- this._dx = 0;
- this._dy = 0;
-- actor.connect('captured-event', this._handleEvent.bind(this));
-+ actor.connect('captured-event::nonmotion', this._handleEvent.bind(this));
- this._touchpadSettings = new Gio.Settings({schema_id: 'org.gnome.desktop.peripherals.touchpad'});
- },
-
diff --git a/PKGBUILD b/PKGBUILD
index 30323dc5d839..f654f8545916 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,8 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
-_pkgname=gnome-shell
-pkgver=3.30.2+4
-pkgrel=7
+pkgver=3.32.0
+pkgrel=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
@@ -21,65 +20,25 @@ optdepends=('gnome-control-center: System settings'
groups=(gnome)
provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
-_commit=2a36bf52cb61ac1a015bc2150807a8d47c7155e4 # tags/3.30.2^0
-source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
- "276.diff"
- "https://gitlab.gnome.org/GNOME/gnome-shell/raw/e26de6865dc6bed3af45355aeb4060e4e0f854d7/js/ui/workspaceThumbnail.js")
+_commit=47915f8c1117470e5351a8ec4e4bdac5e683498d # tags/3.32.0^0
+source=("$pkgname::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
sha256sums=('SKIP'
- 'SKIP'
- 'aee12ef68be36cf8f87e67e00ebd620fe2aa3aac234a16a0ab2b65db1e1fbfdc'
- 'ad16e4defb7e93ed26e663da6e19ec26dd0eeafbc86608598e19278360d23fdd')
+ 'SKIP')
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
prepare() {
- cd $_pkgname
-
- # st-box-layout: Avoid fullscreen relayout on scroll
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/224
- git remote add vanvugt https://gitlab.gnome.org/vanvugt/gnome-shell.git || true
- git fetch vanvugt
- git cherry-pick 6a3dd0fa
- git cherry-pick 5aac3f0a
-
- # js/ui: Use captured-event::nonmotion [performance]
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/276
- # Requires mutter MR283/commit "clutter-actor: Add detail to captured-event signal [performance]"
- if pacman -Q | grep mutter-781835-workaround; then
- git apply ../../276.diff
- echo "======= mutter-781835-workaround detected, MR276 is applied ======="
- sleep 3
- else
- echo "======= mutter-781835-workaround not installed, not applying MR276 ======="
- sleep 3
- fi
-
- # messageTray: Re-enable unredirection when banner is destroyed
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/304
- # Fix performance regression with fullscreen apps, merged in master but not in 3.30
- git cherry-pick e5ce3d54
-
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/343
- # workspaceThumbnail: Clean up porthole/workarea setting and updating
- mv ../workspaceThumbnail.js js/ui/
-
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/364
- # Use ClutterImage on StTextureCache
- git cherry-pick deec0bf2^..3dcb593a
-
- # https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/96/
- # Fixes and performance improvements to the extension system
- git cherry-pick 078cfba1^..0c167543
-
- # Move the plugin to our custom epiphany-only dir
- sed -i "s/'mozilla'/'epiphany'/g" meson.build
-
+ cd $pkgname
git submodule init
git config --local submodule.subprojects/gvc.url "$srcdir/libgnome-volume-control"
git submodule update
}
build() {
- arch-meson $_pkgname build -D gtk_doc=true
+ arch-meson $pkgname build -D gtk_doc=true
ninja -C build
}