summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45bb8250ed6e..43d7ea3bebce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches
- pkgver = 3.32.0+21+g2a7058b83
+ pkgver = 3.32.0+22+g05e55cee2
pkgrel = 1
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
@@ -34,7 +34,7 @@ pkgbase = gnome-shell-performance
optdepends = gnome-control-center: System settings
optdepends = evolution-data-server: Evolution calendar integration
provides = gnome-shell
- provides = gnome-shell=3.32.0+21+g2a7058b83
+ provides = gnome-shell=3.32.0+22+g05e55cee2
conflicts = gnome-shell
source = gnome-shell-performance::git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=05e55cee23d65206f3c3f2d12f4a4d659061651f
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
diff --git a/PKGBUILD b/PKGBUILD
index 639b31f23dfb..8265587591a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Flamelab <panosfilip@gmail.com
pkgname=gnome-shell-performance
-pkgver=3.32.0+20+g05e55cee2
+pkgver=3.32.0+22+g05e55cee2
pkgrel=1
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
@@ -31,7 +31,9 @@ sha256sums=('SKIP'
'939e81f682ebafd60e86d444e49dbab277fba0f00420466b5ff783568b7dc931')
pkgver() {
cd $pkgname
- git describe --tags | sed 's/-/+/g'
+
+ _manual_bump=22 # horrible temporary workaround to account new versioning
+ git describe --tags | sed "s/-/+/g;s/20/$_manual_bump/"
}
prepare() {