summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--276.diff65
-rw-r--r--PKGBUILD14
3 files changed, 78 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a47f96230e5f..c66949f569af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-shell-performance
pkgdesc = Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches
pkgver = 3.30.2+4
- pkgrel = 5
+ pkgrel = 6
url = https://wiki.gnome.org/Projects/GnomeShell
arch = x86_64
groups = gnome
@@ -37,11 +37,13 @@ pkgbase = gnome-shell-performance
provides = gnome-shell=3.30.2+4
conflicts = gnome-shell
source = git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=2a36bf52cb61ac1a015bc2150807a8d47c7155e4
- source = https://gitlab.gnome.org/GNOME/gnome-shell/raw/e26de6865dc6bed3af45355aeb4060e4e0f854d7/js/ui/workspaceThumbnail.js
source = git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git
+ source = 276.diff
+ source = https://gitlab.gnome.org/GNOME/gnome-shell/raw/e26de6865dc6bed3af45355aeb4060e4e0f854d7/js/ui/workspaceThumbnail.js
sha256sums = SKIP
- sha256sums = ad16e4defb7e93ed26e663da6e19ec26dd0eeafbc86608598e19278360d23fdd
sha256sums = SKIP
+ sha256sums = aee12ef68be36cf8f87e67e00ebd620fe2aa3aac234a16a0ab2b65db1e1fbfdc
+ sha256sums = ad16e4defb7e93ed26e663da6e19ec26dd0eeafbc86608598e19278360d23fdd
pkgname = gnome-shell-performance
diff --git a/276.diff b/276.diff
new file mode 100644
index 000000000000..9dcdc88fcbc9
--- /dev/null
+++ b/276.diff
@@ -0,0 +1,65 @@
+diff --git a/js/ui/padOsd.js b/js/ui/padOsd.js
+index 48219026c..9da51c4f2 100644
+--- a/js/ui/padOsd.js
++++ b/js/ui/padOsd.js
+@@ -638,7 +638,7 @@ var PadOsd = new Lang.Class({
+ this._settings = settings;
+ this._imagePath = imagePath;
+ this._editionMode = editionMode;
+- this._capturedEventId = global.stage.connect('captured-event', this._onCapturedEvent.bind(this));
++ this._capturedEventId = global.stage.connect('captured-event::nonmotion', this._onCapturedEvent.bind(this));
+ this._padChooser = null;
+
+ let deviceManager = Clutter.DeviceManager.get_default();
+diff --git a/js/ui/panel.js b/js/ui/panel.js
+index 66588f9c1..6bbf7bc06 100644
+--- a/js/ui/panel.js
++++ b/js/ui/panel.js
+@@ -418,7 +418,7 @@ var ActivitiesButton = new Lang.Class({
+
+ this.actor.label_actor = this._label;
+
+- this.actor.connect('captured-event', this._onCapturedEvent.bind(this));
++ this.actor.connect('captured-event::nonmotion', this._onCapturedEvent.bind(this));
+ this.actor.connect_after('key-release-event', this._onKeyRelease.bind(this));
+
+ Main.overview.connect('showing', () => {
+diff --git a/js/ui/status/system.js b/js/ui/status/system.js
+index c695f37be..1c61ed87e 100644
+--- a/js/ui/status/system.js
++++ b/js/ui/status/system.js
+@@ -32,7 +32,7 @@ var AltSwitcher = new Lang.Class({
+ this._alternate.connect('clicked',
+ () => { this._clickAction.release(); });
+
+- this._capturedEventId = global.stage.connect('captured-event', this._onCapturedEvent.bind(this));
++ this._capturedEventId = global.stage.connect('captured-event::nonmotion', this._onCapturedEvent.bind(this));
+
+ this._flipped = false;
+
+diff --git a/js/ui/viewSelector.js b/js/ui/viewSelector.js
+index 6a235eccd..4a747c834 100644
+--- a/js/ui/viewSelector.js
++++ b/js/ui/viewSelector.js
+@@ -57,7 +57,7 @@ var TouchpadShowOverviewAction = new Lang.Class({
+ Name: 'TouchpadShowOverviewAction',
+
+ _init(actor) {
+- actor.connect('captured-event', this._handleEvent.bind(this));
++ actor.connect('captured-event::nonmotion', this._handleEvent.bind(this));
+ },
+
+ _handleEvent(actor, event) {
+diff --git a/js/ui/windowManager.js b/js/ui/windowManager.js
+index adfee93a9..771391825 100644
+--- a/js/ui/windowManager.js
++++ b/js/ui/windowManager.js
+@@ -477,7 +477,7 @@ var TouchpadWorkspaceSwitchAction = new Lang.Class({
+ _init(actor) {
+ this._dx = 0;
+ this._dy = 0;
+- actor.connect('captured-event', this._handleEvent.bind(this));
++ actor.connect('captured-event::nonmotion', this._handleEvent.bind(this));
+ this._touchpadSettings = new Gio.Settings({schema_id: 'org.gnome.desktop.peripherals.touchpad'});
+ },
+
diff --git a/PKGBUILD b/PKGBUILD
index b5798b8778fa..572a3c7f3125 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=gnome-shell-performance
_pkgname=gnome-shell
pkgver=3.30.2+4
-pkgrel=5
+pkgrel=6
pkgdesc="Next generation desktop shell | Attempt to improve the performance by non-upstreamed patches"
url="https://wiki.gnome.org/Projects/GnomeShell"
arch=(x86_64)
@@ -23,11 +23,13 @@ provides=(gnome-shell gnome-shell=$pkgver)
conflicts=(gnome-shell)
_commit=2a36bf52cb61ac1a015bc2150807a8d47c7155e4 # tags/3.30.2^0
source=("git+https://gitlab.gnome.org/GNOME/gnome-shell.git#commit=$_commit"
- https://gitlab.gnome.org/GNOME/gnome-shell/raw/e26de6865dc6bed3af45355aeb4060e4e0f854d7/js/ui/workspaceThumbnail.js
- "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git")
+ "git+https://gitlab.gnome.org/GNOME/libgnome-volume-control.git"
+ "276.diff"
+ "https://gitlab.gnome.org/GNOME/gnome-shell/raw/e26de6865dc6bed3af45355aeb4060e4e0f854d7/js/ui/workspaceThumbnail.js")
sha256sums=('SKIP'
- 'ad16e4defb7e93ed26e663da6e19ec26dd0eeafbc86608598e19278360d23fdd'
- 'SKIP')
+ 'SKIP'
+ 'aee12ef68be36cf8f87e67e00ebd620fe2aa3aac234a16a0ab2b65db1e1fbfdc'
+ 'ad16e4defb7e93ed26e663da6e19ec26dd0eeafbc86608598e19278360d23fdd')
prepare() {
cd $_pkgname
@@ -43,7 +45,7 @@ prepare() {
# https://gitlab.gnome.org/GNOME/gnome-shell/merge_requests/276
# Requires mutter MR283/commit "clutter-actor: Add detail to captured-event signal [performance]"
if pacman -Q | grep mutter-781835-workaround; then
- git cherry-pick 5a7be719 || bash
+ git apply ../../276.diff
echo "======= mutter-781835-workaround detected, MR276 is applied ======="
sleep 3
else