summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a91b2f38eb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Apr 4 16:32:01 UTC 2016
+pkgbase = gnome-shell-theme-ciliora-secunda-git
+ pkgdesc = Ciliora Tertia GNOME Shell theme.
+ pkgver = r125.4d21682
+ pkgrel = 1
+ url = http://zagortenay333.deviantart.com/art/Ciliora-Secunda-Shell-536134191
+ arch = any
+ license = GPLv3
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-theme-ciliora-secunda
+ source = git+https://github.com/zagortenay333/ciliora-secunda-shell.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-theme-ciliora-secunda-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f92b2320b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname="gnome-shell-theme-ciliora-secunda-git"
+_gitname="ciliora-secunda-shell"
+pkgver=r125.4d21682
+pkgrel=1
+pkgdesc="Ciliora Tertia GNOME Shell theme."
+arch=('any')
+url="http://zagortenay333.deviantart.com/art/Ciliora-Secunda-Shell-536134191"
+license=('GPLv3')
+depends=('gnome-shell')
+makedepends=('git')
+provides=('gnome-shell-theme-ciliora-secunda')
+source=('git+https://github.com/zagortenay333/ciliora-secunda-shell.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_gitname"
+
+ install -d -m 755 ${pkgdir}/usr/share/themes
+ cp -r "Ciliora-Secunda" ${pkgdir}/usr/share/themes
+ cp "gnome-shell-theme.gresource" "$pkgdir/usr/share/themes/Ciliora-Secunda/"
+ install -D -m 644 "README.md" "$pkgdir/usr/share/themes/Ciliora-Secunda/README.md"
+ install -D -m 644 "LICENSE" "$pkgdir/usr/share/themes/Ciliora-Secunda/LICENSE"
+}