summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e94b7adcb16..574e8599f074 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gnome-terminal-fedora
pkgdesc = The GNOME Terminal Emulator with Fedora patches
pkgver = 3.50.1
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Apps/Terminal
arch = i686
arch = x86_64
@@ -13,8 +13,9 @@ pkgbase = gnome-terminal-fedora
makedepends = gnome-shell
makedepends = meson
makedepends = yelp-tools
- depends = vte3-notification>=0.74.0
+ depends = libhandy
depends = gsettings-desktop-schemas
+ depends = vte3-notification>=0.74.0
optdepends = gconf: for gnome-terminal-migration
optdepends = libnautilus-extension: for "Open Terminal Here" in GNOME Files
provides = gnome-terminal=3.50.1
diff --git a/PKGBUILD b/PKGBUILD
index 034c57ebaade..bfb6f0586b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname='gnome-terminal'
pkgname="${_pkgname}-fedora"
pkgver=3.50.1
-pkgrel=1
+pkgrel=2
pkgdesc='The GNOME Terminal Emulator with Fedora patches'
url='https://wiki.gnome.org/Apps/Terminal'
license=('GPL')
@@ -16,8 +16,9 @@ arch=(
'x86_64'
)
depends=(
- 'vte3-notification>=0.74.0'
+ 'libhandy'
'gsettings-desktop-schemas'
+ 'vte3-notification>=0.74.0'
)
makedepends=(
'git'
@@ -62,11 +63,14 @@ prepare () {
}
build() {
- arch-meson build gnome-terminal \
- -D b_lto=false \
- -D docs=true \
- -D nautilus_extension=true \
- -D search_provider=true
+ local meson_options=(
+ -D b_lto=false
+ -D docs=true
+ -D nautilus_extension=true
+ -D search_provider=true
+ )
+
+ arch-meson build gnome-terminal "${meson_options[@]}"
meson compile -C build
}