summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 15 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fe1fbcf77ca..516015a78023 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 15 20:06:35 UTC 2016
+# Sun Mar 5 18:28:59 UTC 2017
pkgbase = gnome-twitch-git
pkgdesc = Enjoy Twitch on your GNU/Linux desktop
- pkgver = r735.1876eff
+ pkgver = r923.7eb89a1
pkgrel = 1
url = https://github.com/vinszent/gnome-twitch
arch = i686
@@ -13,11 +13,6 @@ pkgbase = gnome-twitch-git
depends = gtk3
depends = libsoup
depends = json-glib
- depends = gstreamer
- depends = gst-libav
- depends = gst-plugins-base
- depends = gst-plugins-good
- depends = gst-plugins-bad
depends = webkit2gtk
depends = libpeas
depends = gobject-introspection
diff --git a/PKGBUILD b/PKGBUILD
index 290a3a3195f0..fbd4c73934aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,36 @@
-# Maintainer: Vincent <ippytraxx@installgentoo.com>
+# Maintainer: vinszent <vinszent@vinszent.com>
pkgname=gnome-twitch-git
-pkgver=r735.1876eff
+pkgver=r923.7eb89a1
pkgrel=1
pkgdesc="Enjoy Twitch on your GNU/Linux desktop"
arch=('i686' 'x86_64')
url="https://github.com/vinszent/gnome-twitch"
license=('GPL3')
makedepends=('git' 'meson')
-depends=('gtk3' 'libsoup' 'json-glib' 'gstreamer' 'gst-libav' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'webkit2gtk' 'libpeas' 'gobject-introspection')
+depends=('gtk3' 'libsoup' 'json-glib' 'webkit2gtk' 'libpeas' 'gobject-introspection')
conflicts=('gnome-twitch')
source=("$pkgname::git+https://github.com/vinszent/gnome-twitch.git")
md5sums=('SKIP')
pkgver()
{
- cd "$pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build()
{
- cd "$pkgname"
- rm -rf build
- mkdir build
- cd build
- meson --prefix /usr --libdir lib --buildtype release -Ddo-post-install=false -Dwith-player-gstreamer-cairo=true -Db_lundef=false ..
- ninja
+ cd "$pkgname"
+ rm -rf build
+ mkdir build
+ cd build
+ meson --prefix /usr --libdir lib --buildtype release ..
+ ninja
}
package()
{
- cd "$pkgname"/build
- DESTDIR="$pkgdir" ninja install
+ cd "$pkgname/build"
+ DESTDIR="$pkgdir" ninja install
}