summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
-rw-r--r--requirements.txt5
4 files changed, 50 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0a50e411a9b..824f00d95599 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,32 @@
pkgbase = gns3-gui-git
pkgdesc = GNS3 network simulator. Graphical user interface package.
- pkgver = v2.1.9.r0.g45e00807
+ pkgver = v2.2.39.r2.g7654681a
pkgrel = 1
url = https://github.com/GNS3/gns3-gui
arch = any
groups = gns3
license = GPL3
makedepends = git
- makedepends = python-setuptools
+ depends = desktop-file-utils
+ depends = python-distro
depends = python-jsonschema
- depends = gns3-converter
- depends = python-raven
depends = python-psutil
depends = python-pyqt5
- depends = python-sip
+ depends = python-pyqt5-sip
+ depends = python-sentry_sdk
+ depends = python-setuptools
depends = qt5-svg
depends = qt5-websockets
- depends = desktop-file-utils
- optdepends = gns3-server-git: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.
- optdepends = dynamips: Cisco router emulator.
- optdepends = xterm: Default terminal emulator for CLI management of virtual instances.
- optdepends = wireshark-gtk: Live packet capture.
+ optdepends = gns3-server: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM
+ optdepends = xterm: Default terminal emulator for CLI management of virtual instances
+ optdepends = wireshark-qt: Live packet capture
provides = gns3-gui
conflicts = gns3-gui
- source = gns3-gui::git+git://github.com/GNS3/gns3-gui.git#branch=2.1
+ source = gns3-gui::git+https://github.com/GNS3/gns3-gui.git
source = gns3.desktop
+ source = requirements.txt
sha256sums = SKIP
sha256sums = 51e6db5b47e6af3d008d85e8c597755369fafb75ddb2af9e79a441f943f4c166
+ sha256sums = 0eb0aaa527346f7c120f9305d60994375380facefe03c5dc7c13e50f1122c976
pkgname = gns3-gui-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e68835c0b7c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*~
+*.log
+gns3-gui
+gns3-gui-git-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index c3d604c2b248..c2374cbb8004 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=gns3-gui
pkgname="$_pkgname"-git
-pkgver=v2.1.9.r25.g3000a9aa
+pkgver=v2.2.39.r2.g7654681a
pkgrel=1
pkgdesc='GNS3 network simulator. Graphical user interface package.'
arch=('any')
@@ -12,23 +12,41 @@ license=('GPL3')
groups=('gns3')
provides=('gns3-gui')
conflicts=('gns3-gui')
-makedepends=('git' 'python-setuptools')
-depends=('python-jsonschema' 'gns3-converter' 'python-raven' 'python-psutil'
- 'python-pyqt5' 'python-sip' 'qt5-svg' 'qt5-websockets' 'desktop-file-utils')
-optdepends=('gns3-server-git: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.'
- 'dynamips: Cisco router emulator.'
- 'xterm: Default terminal emulator for CLI management of virtual instances.'
- 'wireshark-gtk: Live packet capture.')
-source=("$_pkgname::git+git://github.com/GNS3/$_pkgname.git#branch=2.1"
- 'gns3.desktop')
+makedepends=('git')
+depends=(
+ 'desktop-file-utils'
+ 'python-distro'
+ 'python-jsonschema'
+ 'python-psutil'
+ 'python-pyqt5'
+ 'python-pyqt5-sip'
+ 'python-sentry_sdk'
+ 'python-setuptools'
+ 'qt5-svg'
+ 'qt5-websockets'
+)
+optdepends=(
+ 'gns3-server: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM'
+ 'xterm: Default terminal emulator for CLI management of virtual instances'
+ 'wireshark-qt: Live packet capture')
+source=("$_pkgname::git+https://github.com/GNS3/$_pkgname.git"
+ 'gns3.desktop'
+ 'requirements.txt')
sha256sums=('SKIP'
- '51e6db5b47e6af3d008d85e8c597755369fafb75ddb2af9e79a441f943f4c166')
+ '51e6db5b47e6af3d008d85e8c597755369fafb75ddb2af9e79a441f943f4c166'
+ '0eb0aaa527346f7c120f9305d60994375380facefe03c5dc7c13e50f1122c976')
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "$_pkgname"
+ # Arch usually has the latest versions. Patch requirements to allow them.
+ cp "$srcdir"/requirements.txt .
+}
+
build() {
cd "$_pkgname"
python setup.py build
diff --git a/requirements.txt b/requirements.txt
new file mode 100644
index 000000000000..e8af62f048ef
--- /dev/null
+++ b/requirements.txt
@@ -0,0 +1,5 @@
+jsonschema>=4.17.3
+sentry-sdk>=1.17.0
+psutil>=5.9.4
+distro>=1.8.0
+setuptools>=60.8.1