summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD31
-rw-r--r--gns3.desktop11
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57f79c7cf55d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gns3-gui-git
+ pkgdesc = GNS3 network simulator. Graphical user interface package.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/GNS3/gns3-gui
+ arch = any
+ groups = gns3
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python-jsonschema>=2.4.0
+ depends = python-raven>=5.23.0
+ depends = python-psutil>=2.2.1
+ depends = python-pyqt5
+ optdepends = gns3-server-git: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.
+ optdepends = dynamips: Cisco router emulator.
+ optdepends = xterm: Default terminal emulator for CLI management of virtual instances.
+ optdepends = wireshark-gtk: Live packet capture.
+ provides = gns3-gui
+ conflicts = gns3-gui
+ replaces = gns3-gui
+ source = gns3-gui-2.0.3.tar.gz::https://github.com/GNS3/gns3-gui/archive/v2.0.3.tar.gz
+ source = gns3.desktop
+ md5sums = 3253ff768b469cabd458bc20b1d38526
+ md5sums = ac6ba60be0a1cb7fc965d1a105e431d5
+
+pkgname = gns3-gui-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82049bc94ca6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Joseph Brains <jnbrains@gmail.com>
+_pkgname=gns3-gui
+pkgname=${_pkgname}-git
+pkgver=2.0.3
+pkgrel=1
+pkgdesc='GNS3 network simulator. Graphical user interface package.'
+arch=('any')
+url="https://github.com/GNS3/${_pkgname}"
+license=('GPL3')
+groups=('gns3')
+provides=('gns3-gui')
+replaces=('gns3-gui')
+conflicts=('gns3-gui')
+makedepends=('python-setuptools')
+depends=('python-jsonschema>=2.4.0' 'python-raven>=5.23.0' 'python-psutil>=2.2.1' 'python-pyqt5')
+optdepends=('gns3-server-git: GNS3 backend. Manages emulators such as Dynamips, VirtualBox or Qemu/KVM.'
+ 'dynamips: Cisco router emulator.'
+ 'xterm: Default terminal emulator for CLI management of virtual instances.'
+ 'wireshark-gtk: Live packet capture.')
+source=("${_pkgname}-${pkgver}.tar.gz::https://github.com/GNS3/${_pkgname}/archive/v${pkgver}.tar.gz"
+ 'gns3.desktop')
+md5sums=('3253ff768b469cabd458bc20b1d38526'
+ 'ac6ba60be0a1cb7fc965d1a105e431d5')
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python setup.py install --root=${pkgdir} --optimize=1
+ install -Dm644 ${srcdir}/gns3.desktop ${pkgdir}/usr/share/applications/gns3.desktop
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}/resources/images/gns3_icon_256x256.png ${pkgdir}/usr/share/pixmaps/gns3.png
+ install -Dm644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE ${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE
+}
diff --git a/gns3.desktop b/gns3.desktop
new file mode 100644
index 000000000000..98458160ea83
--- /dev/null
+++ b/gns3.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=GNS3
+Comment=GNS3 network simulator
+Exec=gns3 %f
+Icon=gns3
+Terminal=false
+Categories=Education;
+MimeType=application/x-gns3;
+Keywords=simulator;network;netsim;