summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD41
-rw-r--r--gdl.profile1
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c19b3e1b1c62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = gnudatalanguage
+ pkgdesc = An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)
+ pkgver = 0.9.5
+ pkgrel = 1
+ url = http://gnudatalanguage.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = python2
+ depends = python2-numpy
+ depends = plplot
+ depends = gsl
+ depends = readline
+ depends = hdf5
+ depends = netcdf
+ depends = netcdf-cxx-legacy
+ depends = wxgtk
+ depends = fftw
+ depends = udunits
+ depends = pslib
+ depends = grib_api
+ depends = udunits
+ depends = eigen3
+ options = !makeflags
+ source = http://downloads.sourceforge.net/gnudatalanguage/gdl-0.9.5.tar.gz
+ source = gdl.profile
+ md5sums = 2d02283c544820729479a57545d5b599
+ md5sums = 40aa5fd8278cd8e80425c62a577563cc
+
+pkgname = gnudatalanguage
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a73c4f4b99b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: James Tappin <jtappinatgmaildotcom>
+# Contributor: Orlando Garcia Feal <rodland at gmail dot com>
+
+pkgname=gnudatalanguage
+pkgver=0.9.5
+pkgrel=1
+pkgdesc="An IDL (Interactive Data Language) compatible incremental compiler (ie. runs IDL programs)"
+arch=('i686' 'x86_64')
+url="http://gnudatalanguage.sourceforge.net/"
+license=('GPL')
+depends=('python2' 'python2-numpy' 'plplot' 'gsl' 'readline' 'hdf5' 'netcdf' \
+ 'netcdf-cxx-legacy' 'wxgtk' 'fftw' 'udunits' 'pslib' 'grib_api' \
+ 'udunits' 'eigen3')
+makedepends=('cmake')
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/gnudatalanguage/gdl-${pkgver}.tar.gz \
+ gdl.profile)
+md5sums=('2d02283c544820729479a57545d5b599'
+ '40aa5fd8278cd8e80425c62a577563cc')
+
+build() {
+ cd $srcdir/gdl-${pkgver}
+ if [[ -d build ]]; then
+ rm -r build
+ fi
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DPYTHON=YES -DPYTHONVERSION=2.7 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2.7 \
+ -DMAGICK=NO -DFFTW=YES -DHDF5=YES -DHDF=NO -DGRIB=YES -DUDUNITS=YES \
+ -DCMAKE_C_FLAGS="-I/usr/include/ImageMagick \
+ -I/usr/include/python2.7 \
+ -I/usr/lib/python2.7/site-packages/numpy/core/include" ..
+ make
+}
+package() {
+ cd $srcdir/gdl-${pkgver}/build
+ make DESTDIR=$pkgdir install
+
+ install -D -m755 ../../gdl.profile $pkgdir/etc/profile.d/gdl.sh
+}
diff --git a/gdl.profile b/gdl.profile
new file mode 100644
index 000000000000..3777162abcdf
--- /dev/null
+++ b/gdl.profile
@@ -0,0 +1 @@
+export GDL_PATH=+/usr/share/gnudatalanguage/lib