summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 75d9efa516df..d118d8646e7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=gnuradio-git
_gitname=gnuradio
-pkgver=v3.11.0.0git.501.g86cde54a7
+pkgver=v3.11.0.0git.717.g72e21b54c
pkgrel=1
pkgdesc="General purpose DSP and SDR toolkit, with drivers for usrp and fcd."
arch=('i686' 'x86_64')
@@ -13,7 +13,8 @@ url="https://github.com/gnuradio/gnuradio"
license=('GPL')
depends=('fftw' 'python' 'python-numpy' 'python-mako' 'python-click' 'python-click-plugins' 'python-pyqt5' 'python-gobject' 'python-packaging' 'python-jsonschema' 'cppunit' 'gsl' 'blas' 'guile' 'boost-libs>=1.54' 'libusb' 'portaudio' 'libuhd' 'zeromq' 'libvolk' 'spdlog' 'gtk3')
makedepends=('git' 'boost' 'cmake' 'python-cairo' 'python-yaml' 'python-cheetah3' 'glu' 'pybind11' 'qwt' 'python-sphinx')
-optdepends=('python-lxml: Some GRC modules use lxml optionally for improved performance')
+optdepends=('python-lxml: Some GRC modules use lxml optionally for improved performance'
+ 'python-qtpy: GNU Radio Companion requires this for the Qt-based front end')
source=("git+https://github.com/gnuradio/gnuradio.git")
md5sums=('SKIP')
conflicts=('gnuradio' 'gnuradio-companion')
@@ -37,7 +38,7 @@ build() {
-DENABLE_INTERNAL_VOLK=OFF \
-DENABLE_GR_CTRLPORT=OFF \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DGR_PYTHON_DIR=/usr/lib/python3.11/site-packages \
+ -DGR_PYTHON_DIR=/usr/lib/python3.12/site-packages \
-DQWT_LIBRARIES=/usr/lib/libqwt.so -Wno-dev ../
make
}