summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD41
-rwxr-xr-xgo-for-it.install16
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1786452336fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = go-for-it-bzr
+ pkgdesc = A stylish to-do list with built-in productivity timer.
+ pkgver = r101
+ pkgrel = 1
+ url = https://code.launchpad.net/~mank319/+junk/go-for-it
+ install = go-for-it.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = vala
+ makedepends = bzr
+ makedepends = cmake
+ depends = gtk3
+ depends = libnotify
+ provides = go-for-it-bzr
+ conflicts = go-for-it-bzr
+ source = bzr+lp:~mank319/+junk/go-for-it
+ sha256sums = SKIP
+
+pkgname = go-for-it-bzr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..58b6a96d34d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Marcin Tydelski <marcin.tydelski@gmail.com>
+# Contributor: Manuel Kehl <https://launchpad.net/~mank319, https://github.com/mank319/>
+
+pkgname=go-for-it-bzr
+pkgver=r101
+pkgrel=1
+pkgdesc='A stylish to-do list with built-in productivity timer.'
+arch=('i686' 'x86_64')
+url='https://code.launchpad.net/~mank319/+junk/go-for-it'
+license=('GPL3')
+depends=('gtk3' 'libnotify')
+optdepends=()
+makedepends=('vala' 'bzr' 'cmake')
+provides=("${pkgname%}")
+conflicts=("${pkgname%}")
+install="${pkgname%-*}.install"
+source=('bzr+lp:~mank319/+junk/go-for-it')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+ printf "r%s" "$(bzr revno)"
+}
+
+build() {
+ cd ${pkgname%-*}
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build && cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-*}/build
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/go-for-it.install b/go-for-it.install
new file mode 100755
index 000000000000..826f632e9bfa
--- /dev/null
+++ b/go-for-it.install
@@ -0,0 +1,16 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -ftq usr/share/icons/hicolor
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file