summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27941a5aaa42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Dec 28 11:04:54 UTC 2016
+pkgbase = go-json-gold
+ pkgdesc = An implementation of the JSON-LD specification in Go
+ pkgver = r30.2e54481
+ pkgrel = 1
+ url = https://github.com/kazarena/json-gold
+ arch = x86_64
+ arch = i686
+ license = APACHE
+ makedepends = rsync
+ depends = go
+ options = !strip
+ options = !emptydirs
+
+pkgname = go-json-gold
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8764d948d760
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sven Schneider <archlinux.sandmann@googlemail.com>
+
+pkgname=go-json-gold
+pkgver=r30.2e54481
+pkgrel=1
+pkgdesc="An implementation of the JSON-LD specification in Go"
+arch=('x86_64' 'i686')
+url="https://github.com/kazarena/json-gold"
+license=('APACHE')
+depends=('go')
+makedepends=('rsync')
+options=('!strip' '!emptydirs')
+_gourl='github.com/kazarena/json-gold'
+
+#pkgver() {
+# cd "${srcdir}/src/${_gourl}"
+# printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+#}
+
+build() {
+ GOPATH="${srcdir}" go get -v -x ${_gourl}/...
+}
+
+package() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgdir}/usr/lib/go"
+ rsync -avz --exclude .git {src,pkg} "${pkgdir}/usr/lib/go"
+
+ install -Dm644 "src/${_gourl}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}