summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 441363c22d6e..5ae1f70baee4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = gocho
pkgdesc = A local area network file-sharing application with nodes auto-discovery
- pkgver = 0.1
- pkgrel = 1
+ pkgver = 0.1.0
+ pkgrel = 2
url = https://github.com/donkeysharp/gocho.git
arch = x86_64
license = MIT
makedepends = unzip
depends = glibc
source = https://github.com/donkeysharp/gocho/releases/download/0.1.0/gocho_0.1.0_linux64.zip
- md5sums = 98ab0acdb74117ecea7403acc92782ac
+ sha256sums = f6964a93f1db666220fc3d393b20b761b5f01c1d8907b03150d33992936cc90c
pkgname = gocho
diff --git a/PKGBUILD b/PKGBUILD
index b0fc806563b6..0c28d6df9de4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,23 @@
# Maintainer: Alejandro Quisbert <alexandro@autistici.org>
pkgname=gocho
-pkgver=0.1
-pkgrel=1
+pkgver=0.1.0
+pkgrel=2
pkgdesc='A local area network file-sharing application with nodes auto-discovery'
arch=('x86_64')
depends=('glibc')
makedepends=('unzip')
url='https://github.com/donkeysharp/gocho.git'
license=('MIT')
-source=('https://github.com/donkeysharp/gocho/releases/download/0.1.0/gocho_0.1.0_linux64.zip')
-md5sums=('98ab0acdb74117ecea7403acc92782ac')
+_gocho_file=gocho_${pkgver}_linux64.zip
+source=("https://github.com/donkeysharp/gocho/releases/download/${pkgver}/gocho_${pkgver}_linux64.zip")
+sha256sums=('f6964a93f1db666220fc3d393b20b761b5f01c1d8907b03150d33992936cc90c')
package() {
cd "${srcdir}"
- unzip --qt gocho_0.1.0_linux64.zip
- install -D gocho "${pkgdir}"/usr/bin/gocho
-
-}
+ unzip --qt $_gocho_file
+ install -D gocho "$pkgdir/usr/bin/gocho"
+
+}