summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a955c604e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = godit
+ pkgdesc = Emacs-like editor written in Go
+ pkgver = 20130106
+ pkgrel = 1
+ url = https://github.com/nsf/godit
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = go
+ makedepends = go-check
+ makedepends = go-termbox>=1-3
+ options = !strip
+ options = !emptydirs
+
+pkgname = godit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbb631fd95b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+
+pkgname=godit
+pkgver=20130106
+pkgrel=1
+pkgdesc='Emacs-like editor written in Go'
+arch=('x86_64' 'i686')
+url='https://github.com/nsf/godit'
+license=('MIT')
+makedepends=('go' 'go-check' 'go-termbox>=1-3')
+options=('!strip' '!emptydirs')
+_gourl=github.com/nsf/godit
+
+build() {
+ cd "$srcdir"
+ GOPATH="$srcdir" go get -v -x ${_gourl}
+}
+
+check() {
+ source /etc/profile.d/go.sh
+ GOPATH="$GOPATH:$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ # Package license (if available)
+ for f in LICENSE COPYING; do
+ if [ -e "$srcdir/src/$_gourl/$f" ]; then
+ install -Dm644 "$srcdir/src/$_gourl/$f" \
+ "$pkgdir/usr/share/licenses/$pkgname/$f"
+ fi
+ done
+ install -Dm755 "$srcdir/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim:set ts=2 sw=2 et: