summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3e7aa89b1450
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = godot3-as-bin
+ pkgdesc = Advanced cross-platform 2D and 3D game engine (3.X Branch), utilize godot3-bin
+ pkgver = 3.5.3
+ pkgrel = 1
+ url = https://godotengine.org
+ arch = x86_64
+ license = MIT
+ depends = libglvnd
+ depends = libxcursor
+ depends = libxi
+ depends = libxinerama
+ depends = libxrandr
+ depends = godot3-bin
+ optdepends = pipewire-alsa
+ optdepends = pipewire-pulse
+ provides = godot3
+ conflicts = godot3
+
+pkgname = godot3-as-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9c10db8b360
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: HurricanePootis <hurricanepootis@protonmail.com>
+pkgname=godot3-as-bin
+pkgver=3.5.3
+pkgrel=1
+pkgdesc="Advanced cross-platform 2D and 3D game engine (3.X Branch), utilize godot3-bin"
+arch=("x86_64")
+url='https://godotengine.org'
+license=('MIT')
+depends=(libglvnd libxcursor libxi libxinerama libxrandr godot3-bin) # Depends() is small due to godot binary static linking libraries
+provides=(godot3)
+conflicts=(godot3)
+optdepends=(pipewire-alsa pipewire-pulse)
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ cat >> "${pkgdir}/usr/bin/godot3" <<EOF
+#!/bin/sh
+/opt/godot3-bin/Godot_v${pkgver}-stable_x11.64 "\$@"
+EOF
+ chmod +x "${pkgdir}/usr/bin/godot3"
+}