summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rwxr-xr-xgodots.desktop10
3 files changed, 8 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89a2c362ce0e..9b8c367d933c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = godots-git
pkgdesc = A hub for managing your Godot versions and projects.
pkgver = 1.3.stable.r6.gc152061
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MakovWait/godots
arch = x86_64
license = MIT
makedepends = git
makedepends = godot=4.3
+ provides = godots
conflicts = godots
conflicts = godots-bin
- noextract = Godot_v4.3-stable_export_templates.tpz
options = !strip
source = git+https://github.com/MakovWait/godots.git
source = https://github.com/godotengine/godot/releases/download/4.3-stable/Godot_v4.3-stable_export_templates.tpz
diff --git a/PKGBUILD b/PKGBUILD
index 3559ba767398..3f6181db071e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: DragonWoven
pkgname="godots-git"
pkgver=1.3.stable.r6.gc152061
-pkgrel=2
+pkgrel=3
pkgdesc="A hub for managing your Godot versions and projects."
url="https://github.com/MakovWait/godots"
license=("MIT")
arch=("x86_64")
-provides=()
+provides=('godots')
conflicts=('godots' 'godots-bin')
replaces=()
depends=()
source=("git+https://github.com/MakovWait/godots.git" "https://github.com/godotengine/godot/releases/download/4.3-stable/Godot_v4.3-stable_export_templates.tpz")
-noextract=("Godot_v4.3-stable_export_templates.tpz")
makedepends=('git' 'godot=4.3')
b2sums=()
options=("!strip")
@@ -21,7 +20,7 @@ pkgver() {
git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){
- sed -i "s|custom_template/release=\"\"|custom_template/release=\"$srcdir/Godot_v4.3-stable_export_templates.tpz\"|" godots/export_presets.cfg
+ sed -i "s|custom_template/release=\"\"|custom_template/release=\"$srcdir/templates/linux_release.x86_64\"|" godots/export_presets.cfg
}
@@ -29,12 +28,13 @@ build(){
cd "${pkgname%-git}"
mkdir build
- godot --headless --export-debug "Linux/X11" build/godots
+ rm -R tests
+ godot --headless --export-release "Linux/X11" build/godots
}
package(){
install -Dm644 "${pkgname%-git}/icon.svg" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.svg"
- install -Dm644 "../godots.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 "${pkgname%-git}/packaging/linux/io.github.MakovWait.Godots.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
install -Dm755 "${pkgname%-git}/build/godots" "$pkgdir/usr/bin/godots"
}
diff --git a/godots.desktop b/godots.desktop
deleted file mode 100755
index 6cb5f556e4bf..000000000000
--- a/godots.desktop
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/usr/bin/env xdg-open
-[Desktop Entry]
-Version=1.3
-Type=Application
-Name=Godots
-GenericName=Godot Manger
-Comment=hub for managing your Godot versions and projects
-Icon=godots
-Exec=godots
-Categories=Development;