summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
-rw-r--r--gog-tis-100.desktop10
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe144465dc90
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gog-tis-100
+ pkgdesc = The assembly language programming game you never asked for!
+ pkgver = 2.0.0.3
+ pkgrel = 1
+ url = http://www.zachtronics.com/tis-100/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl2
+ source = gog://gog_tis_100_2.0.0.3.sh
+ source = gog-tis-100.desktop
+ sha256sums = e89421857a83ba0ac2fba7f813f2f8d85a6555351ba2bf7905e46fe170099a7f
+ sha256sums = d2303362037e5aa3ffeb01d64b00ffb5160034d88c381e755730827566c7c9d6
+
+pkgname = gog-tis-100
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19e94ba09d04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: James Zhu <james.zhu.engineer@gmail.com>
+
+pkgname=gog-tis-100
+pkgver=2.0.0.3
+pkgrel=1
+pkgdesc="The assembly language programming game you never asked for!"
+url="http://www.zachtronics.com/tis-100/"
+license=('custom')
+arch=('i686' 'x86_64')
+depends=('sdl2')
+source=("gog://${pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop")
+sha256sums=('e89421857a83ba0ac2fba7f813f2f8d85a6555351ba2bf7905e46fe170099a7f'
+ 'd2303362037e5aa3ffeb01d64b00ffb5160034d88c381e755730827566c7c9d6')
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u - This is is not a real URL, you need to download the GOG file manually to \"$PWD\" or setup a gog:// DLAGENT. Read this PKGBUILD for more information.")
+
+prepare(){
+ # Unzip will produce an error code because it is unable to unzip the Installer.
+ # Therefore, a conditional into a no-op command will keep the PKGBUILD from failing
+ # Of course, if you have any real problems unzipping the PKGBUILD will not abort.
+ unzip "${pkgname//-/_}_${pkgver}.sh" || :
+ cd "${srcdir}/data/noarch"
+
+ sed -r -i \
+ 's/(CURRENT_DIR="\$\( cd "\$\( dirname )'`
+ `'"\$\{BASH_SOURCE\[0\]\}"(.*$)'`
+ `'/\1$( readlink -nf "${BASH_SOURCE[0]}" )\2/' \
+ "start.sh"
+}
+
+package(){
+ cd "${srcdir}/data/noarch"
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "game/" "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 "start.sh" \
+ "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ ln -s "/opt/${pkgname}/start.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/gog-tis-100.desktop b/gog-tis-100.desktop
new file mode 100644
index 000000000000..f3333b914362
--- /dev/null
+++ b/gog-tis-100.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=TIS-100
+Comment=The assembly game you never asked for!
+Exec=gog-tis-100
+Icon=gog-tis-100
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Game;AudioVideo;