summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore9
-rw-r--r--PKGBUILD48
-rw-r--r--gog-unreal-tournament-goty4
-rw-r--r--gog-unreal-tournament-goty.desktop8
5 files changed, 58 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00377610cf77..e950d9212864 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,28 @@
pkgbase = gog-unreal-tournament-goty
pkgdesc = Unreal Tournament (99): Game of the Year Edition. GOG Version.
pkgver = 2.0.0.5
- pkgrel = 4
+ pkgrel = 5
url = https://www.gog.com/game/unreal_tournament_goty
arch = x86_64
+ license = MIT
+ license = BSD
+ license = ZLIB
+ license = GPL2
+ license = LGPL2.1
+ license = ZLIB
+ license = OFL
+ license = Apache
license = custom
makedepends = innoextract
depends = lib32-sdl
depends = lib32-libgl
- noextract = ut99v451-linux.tar.gz
+ noextract = OldUnreal-UTPatch469a-Linux.tar.bz2
source = setup_ut_goty_2.0.0.5.exe::gogdownloader://unreal_tournament_goty/en1installer0
source = https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469a/OldUnreal-UTPatch469a-Linux.tar.bz2
- source = gog-unreal-tournament-goty
+ source = gog-unreal-tournament-goty.desktop
sha256sums = 4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803
sha256sums = d521a8339b80a4c86019c3648fb55cfc29edffeec73047ceb72784b159cc84f1
- sha256sums = 2b70aa7a20d5b1fbfaf9561bd3cfc8c1d0f0dee2212b3914aed30a7c75e40566
+ sha256sums = 60a0211a47a4d1b2c6b31da4ecd4848fcb3338dc06430599969c77dc6a5d87e0
pkgname = gog-unreal-tournament-goty
diff --git a/.gitignore b/.gitignore
index 850c3346ca7b..97d0f40fa4a8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,4 @@
-src
-pkg
-*.pkg.tar*
-*.tar.bz2
-*.exe
+*
+!.SRCINFO
+!gog-unreal-tournament-goty.desktop
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 226932a1fc4d..64b77f7a4594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,55 @@
# Maintainer: Zacharias Knudsen <zachasme@gmail.com>
pkgname=gog-unreal-tournament-goty
pkgver=2.0.0.5
-pkgrel=4
+pkgrel=5
pkgdesc="Unreal Tournament (99): Game of the Year Edition. GOG Version."
arch=('x86_64')
url="https://www.gog.com/game/unreal_tournament_goty"
-license=('custom')
+# https://github.com/OldUnreal/UnrealTournamentPatches/blob/v469a/LICENSE.md
+license=('MIT' 'BSD' 'ZLIB' 'GPL2' 'LGPL2.1' 'ZLIB' 'OFL' 'Apache' 'custom')
depends=('lib32-sdl'
'lib32-libgl')
makedepends=('innoextract')
source=("setup_ut_goty_$pkgver.exe::gogdownloader://unreal_tournament_goty/en1installer0"
"https://github.com/OldUnreal/UnrealTournamentPatches/releases/download/v469a/OldUnreal-UTPatch469a-Linux.tar.bz2"
- "gog-unreal-tournament-goty")
-noextract=("ut99v451-linux.tar.gz")
+ "gog-unreal-tournament-goty.desktop")
+noextract=("OldUnreal-UTPatch469a-Linux.tar.bz2")
sha256sums=("4cc257d54d97659c5062f2bf186d0a8c6959561d11e42d8fcf2eac07f1926803"
"d521a8339b80a4c86019c3648fb55cfc29edffeec73047ceb72784b159cc84f1"
- "2b70aa7a20d5b1fbfaf9561bd3cfc8c1d0f0dee2212b3914aed30a7c75e40566")
-DLAGENTS+=("gogdownloader::/usr/bin/echo %u Download the GOG file to \"$PWD\" or set up a gogdownloader:// DLAGENT.")
+ "60a0211a47a4d1b2c6b31da4ecd4848fcb3338dc06430599969c77dc6a5d87e0")
+
+# If you want to use lgogdownloader add the following to /etc/makepkg.conf
+# DLAGENTS+=('goggogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find setup_ut_goty_$pkgver.exe (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf.")
prepare() {
# extract gog installer
- innoextract -em -d $srcdir setup_ut_goty_${pkgver}.exe
- # extract extra linux files
- tar -xf OldUnreal-UTPatch469a-Linux.tar.bz2 -C app
+ innoextract --extract --exclude-temp setup_ut_goty_$pkgver.exe
+
+ # extract linux patches
+ tar --extract --file OldUnreal-UTPatch469a-Linux.tar.bz2 --directory app
+
+ # To put extra content (extra levels/mods) into the game
+ # create an "addons/" folder next to the PKGBUILD.
+ # Whatever is in there will get copied to the root of the game's directory.
+ cp -r $startdir/addons/* app/ 2>/dev/null || :
}
package() {
- # make destination directory
- mkdir -p $pkgdir/opt/gog/$pkgname
+ # make destination directories
+ mkdir -p "$pkgdir/opt/gog"
+ mkdir -p "$pkgdir/usr/bin"
+
# copy game files
- cp -r app/* $pkgdir/opt/gog/$pkgname
- # copy runner to /usr/bin
- install -D -m 755 $pkgname $pkgdir/usr/bin/$pkgname
+ cp -r app "$pkgdir/opt/gog/${pkgname#gog-}"
+
+ # fix permissions
+ chmod 777 -R $pkgdir/opt/gog/${pkgname#gog-}
+
+ # symlink ut binary which is located in /opt
+ ln --symbolic "$pkgdir/opt/gog/${pkgname#gog-}/System/ut-bin" "$pkgdir/usr/bin/$pkgname"
+
+ # install desktop and license
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/applications" $pkgname.desktop
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" app/LICENSE.md
}
diff --git a/gog-unreal-tournament-goty b/gog-unreal-tournament-goty
deleted file mode 100644
index 5098b0e89081..000000000000
--- a/gog-unreal-tournament-goty
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-mkdir -p $HOME/.loki/ut/System
-cd /opt/gog/gog-unreal-tournament-goty/System
-./ut-bin
diff --git a/gog-unreal-tournament-goty.desktop b/gog-unreal-tournament-goty.desktop
new file mode 100644
index 000000000000..0265316cbe4a
--- /dev/null
+++ b/gog-unreal-tournament-goty.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=UT99
+Exec=/opt/gog/unreal-tournament-goty/System/ut-bin
+Comment=Unreal Tournament (99): Game of the Year Edition. GOG Version.
+Terminal=false
+Icon=/opt/gog/unreal-tournament-goty/System/Unreal.ico
+Type=Application
+Categories=Game; \ No newline at end of file