summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7df0addfc183
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = goji
+ pkgdesc = Command line JIRA client
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/kylef/goji
+ arch = any
+ license = BSD
+ makedepends = python-pip
+ makedepends = python-poetry
+ depends = python
+ depends = python-click
+ depends = python-requests
+ depends = python-pysocks
+ depends = python-toml
+ depends = python-jsonschema
+ source = goji-0.4.0.tar.gz::https://github.com/kylef/goji/archive/0.4.0.tar.gz
+ sha1sums = de7bcd57979fe9c1d58ea5166991cfa404039769
+
+pkgname = goji
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a410dd72b94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Kyle Fuller <kyle@fuller.li>
+
+pkgname=goji
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Command line JIRA client"
+url="https://github.com/kylef/goji"
+depends=('python' 'python-click' 'python-requests' 'python-pysocks' 'python-toml' 'python-jsonschema')
+# fixme depends on requests-html
+makedepends=('python-pip' 'python-poetry')
+license=('BSD')
+arch=('any')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kylef/goji/archive/$pkgver.tar.gz")
+sha1sums=('de7bcd57979fe9c1d58ea5166991cfa404039769')
+
+build() {
+ cd "$pkgname-$pkgver"
+ poetry build --format wheel
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/goji/LICENSE"
+
+ export PYTHONHASHSEED=0
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps "dist/$pkgname-$pkgver-"*".whl"
+}