summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD14
-rw-r--r--add-missing-include-limits-for-std-numeric_limits.patch24
2 files changed, 34 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 23aab023a54c..74e6d4738fad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Ammann Max <maximilian.ammann@googlemail.com>
pkgname=golden-cheetah-git
-pkgver=v3.6.DEV2009.r113.e24d25ff4
+pkgver=v3.6.DEV2101.r155.a5043d1b5
pkgrel=1
pkgdesc="Cycling Power Analysis Software. We believe that cyclists and triathletes should be able to download their power data to the
computer of their choice, analyze it in whatever way they see fit, and share their methods of
@@ -8,15 +8,20 @@ analysis with others."
arch=('i686' 'x86_64')
url="http://www.goldencheetah.org/"
license=('GPL')
-makedepends=(bison flex 'gcc' 'make' 'qt5-tools' sip pkgconf)
+makedepends=(bison flex 'gcc' 'make' 'qt5-tools' sip4 pkgconf)
depends=('qt5-base' 'qt5-svg' qt5-location qt5-declarative qt5-webchannel qt5-webengine qt5-sensors qt5-serialport qt5-webkit qt5-multimedia qt5-script qt5-connectivity qt5-charts vlc gsl)
optdepends=('vlc' 'srmio' 'libftd2xx' 'libkml' 'libical' 'libusb-compat' 'libsamplerate')
options=('!strip' '!buildflags' 'staticlibs')
conflicts=('golden-cheetah-rc' 'golden-cheetah-dev' 'golden-cheetah')
source=('golden-cheetah::git+https://github.com/GoldenCheetah/GoldenCheetah.git'
GoldenCheetah.desktop gc.png gcconfig.pri
-'https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch')
-sha256sums=(SKIP 6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e 2959d5570f271feec4de6277fb45208d987d20645185adf069e189dd32ba66b0 b98d4667711d1af37d439619de576352dc06321340da0834723cb7f258fdcab3)
+'https://patch-diff.githubusercontent.com/raw/GoldenCheetah/GoldenCheetah/pull/3628.patch' add-missing-include-limits-for-std-numeric_limits.patch)
+sha256sums=('SKIP'
+ '6c4f56ba53f2deadec5b16efdecd1311653c2dca2c0378f951672a9b7186f09d'
+ 'e12471b7864adc877c34cd4cfb23451cae7648b9c8109f400f1af883d4c8cd4e'
+ '2959d5570f271feec4de6277fb45208d987d20645185adf069e189dd32ba66b0'
+ 'b98d4667711d1af37d439619de576352dc06321340da0834723cb7f258fdcab3'
+ 'fa9a6b200efaeda0a4cda31782e5c4d4bd96ba919b2c07e4ace81a61b0cc054a')
pkgver() {
cd "${srcdir}/golden-cheetah"
@@ -26,6 +31,7 @@ pkgver() {
prepare() {
cd "${srcdir}/golden-cheetah/"
patch --forward --strip=1 --input="${srcdir}/3628.patch"
+ patch --forward --strip=1 --input="${srcdir}/add-missing-include-limits-for-std-numeric_limits.patch"
}
build() {
diff --git a/add-missing-include-limits-for-std-numeric_limits.patch b/add-missing-include-limits-for-std-numeric_limits.patch
new file mode 100644
index 000000000000..c8a1b604e3c6
--- /dev/null
+++ b/add-missing-include-limits-for-std-numeric_limits.patch
@@ -0,0 +1,24 @@
+From c2ce52367b265f9e7b259457c7fd164e14ffb9e3 Mon Sep 17 00:00:00 2001
+From: oxidative
+Date: Thu, 3 Jun 2021 02:09:54 +0200
+Subject: [PATCH] added missing include <limits> for std::numeric_limits
+
+---
+ src/Metrics/BlinnSolver.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/Metrics/BlinnSolver.cpp b/src/Metrics/BlinnSolver.cpp
+index 59f5e5bf9..b424d4687 100644
+--- a/src/Metrics/BlinnSolver.cpp
++++ b/src/Metrics/BlinnSolver.cpp
+@@ -18,6 +18,7 @@
+
+ #include <cmath>
+ #include <algorithm>
++#include <limits>
+ #include "BlinnSolver.h"
+
+ int GetExponent(double a) {
+--
+2.31.1
+