aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD45
-rw-r--r--README.md2
-rw-r--r--golings.install3
-rw-r--r--install.sh78
-rwxr-xr-xtest.sh1
6 files changed, 34 insertions, 123 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b3ff764a9006..0b389c1b65cc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,15 @@
-pkgbase = pkgbase
- pkgdesc = Open-source YANG API in C and CLI (yangcli) and server (netconfd)
- pkgver = latest
+pkgbase = golings
+ pkgdesc = Rustlings for Golang this time
+ pkgver = 0.6.2
pkgrel = 1
- url = https://github.com/vlvassilev/yuma123
+ url = https://github.com/mauricioabreu/golings
+ install = golings.install
arch = x86_64
- license = BSD
- depends = git
- depends = autoconf
- depends = automake
- depends = libtool
- depends = make
- depends = gcc
- provides = yuma123
- conflicts = yuma123
- source = git+https://github.com/vlvassilev/yuma123
- sha256sums = SKIP
+ license = APACHE
+ depends = go
+ provides = golings
+ conflicts = golings
+ source = https://github.com/mauricioabreu/golings/releases/download/v0.6.2/golings_0.6.2_Linux_x86_64.tar.gz
+ sha256sums = 3235016060403a807961d5bda9643104fea022a6283eb09ebb4bbc36131a28c7
-pkgname = yuma123-git
+pkgname = golings
diff --git a/PKGBUILD b/PKGBUILD
index e8b83811a57b..a563bb379c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
-# Maintainer: Joar Heimonen <joarheimonen@live.no>
-# Note: This is only an install script for Yuma123, not the actual project itself.
-
-pkgname=yuma123-git
-pkgver=latest
+# Maintainer: Riel Joseph <bulaybulay.rielj@gmail.com>
+pkgname=golings
+pkgver=0.6.2
pkgrel=1
-pkgdesc="Open-source YANG API in C and CLI (yangcli) and server (netconfd)"
+pkgdesc="Rustlings for Golang this time"
arch=('x86_64')
-url="https://github.com/vlvassilev/yuma123"
-license=('BSD')
-depends=('git' 'autoconf' 'automake' 'make' 'gcc')
-makedepends=('libtool') # Add libtool as a build dependency
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-pkgbase=yuma123-git
-
-source=("git+https://github.com/vlvassilev/yuma123")
+url="https://github.com/mauricioabreu/golings"
+license=('APACHE')
+depends=('go')
+provides=("golings")
+conflicts=("golings")
+install="golings.install"
+source=("https://github.com/mauricioabreu/golings/releases/download/v${pkgver}/${pkgname}_${pkgver}_Linux_x86_64.tar.gz")
+sha256sums=('3235016060403a807961d5bda9643104fea022a6283eb09ebb4bbc36131a28c7')
prepare() {
- cd "$srcdir/yuma123"
- libtoolize
- autoreconf -i -f
-}
-
-build() {
- cd "$srcdir/yuma123"
- ./configure CFLAGS='-g -O0' CXXFLAGS='-g -O0' --prefix=/usr
- make
+ wget "$source" -O ${pkgname}_${pkgver}_Linux_x86_64.tar.gz
}
package() {
- cd "$srcdir/yuma123"
- make DESTDIR="${pkgdir}" install
- mv "${pkgdir}/usr/sbin" "${pkgdir}/usr/bin"
+ tar -xvf ${pkgname}_${pkgver}_Linux_x86_64.tar.gz
+ install -D golings -t "$pkgdir"/usr/bin/
+ install -Dm 644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}
-sha256sums=('SKIP') \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..2c614e760aa7
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+You still need to clone the official golings repository ( https://github.com/mauricioabreu/golings )!
+This is just a way to add the command with pacman.
diff --git a/golings.install b/golings.install
new file mode 100644
index 000000000000..a3dba268b267
--- /dev/null
+++ b/golings.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "You still need to clone the official golings repository!"
+}
diff --git a/install.sh b/install.sh
deleted file mode 100644
index ddc8827df6df..000000000000
--- a/install.sh
+++ /dev/null
@@ -1,78 +0,0 @@
-basename=slk-eng
-pkgname=dict-freedict-$basename
-dictd_conf=/etc/dict/dictd.conf
-datadir=/usr/share/dictd
-conf="database $basename {
- data $datadir/$basename.dict.dz
- index $datadir/$basename.index
-}"
-
-post_install()
-{
- echo
- if pacman -Qq dictd > /dev/null 2>&1
- then
- if grep -q "^database *$basename" "$dictd_conf"
- then
- echo "$pkgname already configured in $dictd_conf"
- else
- echo "Adding configuration for $pkgname to $dictd_conf"
- echo "$conf" >> "$dictd_conf"
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "use the new dictionary database"
- systemctl restart dictd.service
- else
- echo "Starting dictd service in order to" \
- "use the new dictionary database"
- systemctl start dictd.service
- fi
- else
- echo "dictd does not appear to be installed."
- echo "In order to use this database you should either" \
- "install dictd or alternatively" \
- "another dict server and configure it on your own."
- fi
- echo
-}
-
-post_upgrade()
-{
- if pacman -Qq dictd > /dev/null 2>&1 && \
- systemctl -q is-active dictd.service
- then
- echo -e "\nRestarting dictd service in order to" \
- "use the updated dictionary database"
- systemctl restart dictd.service
- fi
-}
-
-post_remove()
-{
- if pacman -Qq dictd > /dev/null 2>&1
- then
- current_conf="$(grep -A 3 "^database *$basename" "$dictd_conf")"
- if test -n "$current_conf"
- then
- echo
- if test "$current_conf" = "$conf"
- then
- echo "Removing configuration for $pkgname from $dictd_conf"
- sed -i "/database $basename {/,/}/d" "$dictd_conf"
- else
- echo "User created / modified configuration" \
- "for $pkgname in $dictd_conf is left untouched."
- fi
- fi
-
- if systemctl -q is-active dictd.service
- then
- echo "Restarting dictd service in order to" \
- "stop using the removed dictionary database"
- systemctl restart dictd.service
- fi
- fi
-}
diff --git a/test.sh b/test.sh
deleted file mode 100755
index 36f0670f54d0..000000000000
--- a/test.sh
+++ /dev/null
@@ -1 +0,0 @@
-echo 'test'