summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a4d0118694c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gomphotherium
+ pkgdesc = A command line Mastodon client
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/mrusme/gomphotherium
+ arch = any
+ license = GPL-3.0-or-later
+ makedepends = make
+ makedepends = go>=1.19
+ depends = glibc
+ source = gomphotherium-0.4.0.tar.gz::https://github.com/mrusme/gomphotherium/archive/refs/tags/v0.4.0.tar.gz
+ sha256sums = 5b72f85b49dde6566644469c2c9727892d8b811333b32329c53dd66e9cd2e065
+
+pkgname = gomphotherium
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3e5c020be266
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: vitaliikuzhdin <vitaliikuzhdin@gmail.com>
+
+pkgname="gomphotherium"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="A command line Mastodon client"
+arch=('any')
+url="https://github.com/mrusme/${pkgname}"
+license=('GPL-3.0-or-later')
+depends=('glibc')
+makedepends=('make' 'go>=1.19')
+_pkgsrc="${pkgname}-${pkgver}"
+source=("${_pkgsrc}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('5b72f85b49dde6566644469c2c9727892d8b811333b32329c53dd66e9cd2e065')
+
+build() {
+ cd "${srcdir}/${_pkgsrc}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgsrc}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}