summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51be88dbe963..23cef4c99adf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = google-cloud-ops-agent-git
pkgdesc = Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)
- pkgver = 2.37.0.r5.g5eee229a3
+ pkgver = 2.42.0.r4.g277352dd2
pkgrel = 1
url = https://github.com/GoogleCloudPlatform/ops-agent
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 67163e1e3ee7..8723c6b2a56a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: shulhan <ms@kilabit.info>
pkgname=google-cloud-ops-agent-git
-pkgver=2.37.0.r5.g5eee229a3
+pkgver=2.42.0.r4.g277352dd2
pkgrel=1
pkgdesc="Ops Agents that are part of the Google Cloud Operations product suite (specifically Cloud Logging and Cloud Monitoring)"
@@ -68,17 +68,28 @@ prepare() {
build() {
_destdir="$srcdir/../staging"
mkdir -p "$_destdir"
- echo "destdir: $_destdir"
+ echo "--- Destination dir: $_destdir"
+ echo "--- Applying patches ..."
cd "${pkgname}"
git apply "${srcdir}/0001-build-sh.patch"
+ echo "--- Building otel ..."
CGO_ENABLED=1 ./builds/otel.sh "$_destdir"
+
+ echo "--- Building fluent_bit ..."
./builds/fluent_bit.sh "$_destdir"
+
+ echo "--- Building systemd ..."
./builds/systemd.sh "$_destdir"
+
+ echo "--- Building ops_agent_diagnostics ..."
./builds/ops_agent_diagnostics.sh "$_destdir"
+
+ echo "--- Building agent_wrapper ..."
./builds/agent_wrapper.sh "$_destdir"
+ echo "--- Building ..."
BUILD_DISTRO=arch CODE_VERSION="${pkgver}" DESTDIR="$_destdir" \
./build.sh
}